Missing something to log phones debug to syslog

Hello All,

I’m trying to configure the FreePBX server so I can write debug info to syslog from the cisco phones and I’m missing something.
Running 6.x Centos and FreePBX 4.211.64-6.

I added rules to the firewall to allow port 514:
-A INPUT -p udp -m udp --dport 514 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 514 -j ACCEPT

I added settings in /etc/syslog.conf
local2.debug,local3.debug /var/log/cisco-phones.log

I un commented the following lines in /etc/rsyslog.conf
$ModLoad imudp
$UDPServerRun 514

$ModLoad imtcp
$InputTCPServerRun 514

I updated the phone templates to add the syslog server and put the debug level to 3.

Once everything is restarted, I’m not seeing any entries in any log files.

I know in the old syslog you needed to add -r parameter but thats not liked in rsyslog.
Not sure what else I’ve missed.

Any help appreciated!