Missing field input field in "extensions"

On one of our PBX (both on version: 15.0.17.55, Asterisk: 16.20) under “Applications>Extensions” the field “Context” is missing from the “Advanced” page while it should be located under the “DTMF Signaling” field.

I’m seeing it. What type of extension? Do you get the same result if you browse from a different browser or in incognito mode?

@lgaetz Same version here and I don’t see it on my chan_pjsip or chan_sip extensions either.

I know I had it at one point because I have custom values I set I can lookup in MySQL.

Extension type is PJSIP, does not work on Firefox, Chrome, Edge. Different PBX does show the option. Could it be because we have Class of Service?

How weird. I’m using core module ver 15.0.12.89 and I can see context on pjsip extensions. Nothing I do will make it go away.

Server I installed a couple weeks ago on 15.0.16.81 and I can see it just fine, so maybe something with 15.0.17.55?

What i’ve noticed is that this is only happening on the box which has class of service enabled. All other ones without Class of Service are displaying that field.

That doesn’t fix it for me. Only common denominator so far is 15.0.17.55.

I see the same. It’s not enough for COS to be enabled, the PJSIP extension must be included in a configured COS. If it is, then the context field does not show on advanced tab.

Pretty sure this is a bug, open an issue pls at https://issues.freepbx.org/

Except I have the same problem and I never even used COS. Then I deleted the module and it’s still the same

Possible other causes as well. I can definitely repro by adding a pjsip ext to a COS.

1 Like