Migration procedure from 32bit FreePBX v13 to 64bit FreePBX v14

I’m trying to figure out the best way to migrate my production PBX from the currently running 32 bit v13 onto a new server and clean install of 64 bit v14. Note that my v13 box is very large, (500 phones, 1100 extensions) to the point where the backup and restore module fails because the backups are too large. I have tried to backup various parts instead of a full backup and move them over. the restore on the v14 box appears to run, it does not give any errors, but no data appears. i have workarounds for some of the things I need to migrate, but not all… Below is a list of the pieces I need to migrate and if I have a workaround or not.

Extensions (bulk Handler works)
DIDs (bulk handler works)
Users and Groups (bulk handler works, but all users passwords must be reset)
IVRs (can recreate manually if needed)
Ring Groups (can recreate manually if needed)
Inbound and Outbound Routes/Trunks (can recreate manually if needed)
Paging and Intercom (can recreate manually if needed)
Misc Applications and Destinations (can recreate manually if needed)
Wakeup calls (can recreate manually if needed)

These are the pieces that are deal breakers, and i cannot recreate them, so they have to be backed up/restored somehow. I believe my big problem is that the backup file is greater than 2GB which is why i think the 32 bit version v13 has a PHP crash if you try and download the file. not sure how to get around it

Voicemail, greetings, VM passwords (must have and cannot recreate)
Directories (must have, cannot recreate)
EndPoint Manager Configuration data (all Polycom VVX410 phones, must have, cannot recreate)

I have another possible solution. I could pull one of the mirrored drives and then try an inplace upgrade of the production box. I’m not sure how that will affect stability going forward, or if doing an upgrade from 32bit to 64 bit v13 to v14 is even possible.

Thoughts? Sorry for the long post… Thanks for any help you can give.


O> M> G> James - This is awesome! I have no clue how I wasn’t aware of this. GREAT job! Thank you so much for the reply and great utility!

1 Like

James, I hate to look the gift horse in the mouth - but I have run the script several times. I do not get any errors, but it is not bringing across voicemails, or the TFTPboot directory. I have tried answering both yes and no to the questions at the beginning as well. I don’t care about the backup directory - and I could deal with the TFTPBoot if I have to, but all users have voicemail disabled, and it will be a mess for 900+ people to recreate all their names and greetings again. Remember my old machine is Freepbx distro 32bit, not sure if that is the issue…The sizes of those folders are below - right from the script.

Directory /var/spool/asterisk/backup? (35.91GB) [yN] Y
Directory /var/spool/asterisk/voicemail? (6.81GB) [yN] Y
Directory /tftpboot? (1.88GB) [yN] Y

Any thoughts?

Known issue:
At present you must manually xfer the contents of these folders. I like rsync.

Also a known issue with an easy fix, see my note in this ticket:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.