Migrating from 2.6 to 2.7 failed, please help!

When I upgrade from 2.6 to 2.7, IVR module failed with this message:

ALTER TABLE ivr CHANGE COLUMN announcement announcement VARCHAR ( 255 ) [nativecode=1054 ** Unknown column ‘announcement’ in ‘ivr’]

What went wrong and how can I fix this? Thanks for your help! Please!!!

Now my 2.6 IVR is no there any more and 2.7 IVR is not installed :frowning:
What could I do to get this 2.7 IVR installed? The Module Admin will always give me that FATAL ERROR message when I tried to install it…

hmm - interesting how you are getting that error? What version of the IVR do you have installed?

It should only be running that test if your version is less than 2.2 and even then, that column should be in the table.

So … something strange is up on your system if that column is missing because a quick check back to 2.1 still has that column.

So … the simplest solution would be to uninstall it if it allows that (and lose all your IVR data). Or you could manually add that column and then install it again. However, that the fact that this column is missing, I would be more worried that something else happened and be inclined to uninstall and re-install it.

There is really nothing that change on 2.7 with IVRs off the top of my head, other than a few bug fixes. Nothing with the schema though.

I had a consultant installed 2.6 for me. After he finished, I noticed the problem *65 always report the largest extension number. Without successfully get the consultant fixing the problem, I decided to try upgrade to 2.7 myself. All core modules updated fine. But when I updating the ivr, I got this error.

One little details, during upgrade, there was an error message saying failed remove the /var/www/…/ivr, so I logged in as root noticed the directory was already empty, and rm -rf ivr. That get rid of the error message of can not remove /var/www…/ivr error. But got a fatal error instead.

How can get move pass this problem? There is no force option in module admin.

hmm … seems like there are a lot of “consultants” breaking people these days. I would question what else is broken on your system considering the things you are reporting…

I thought you could just delete the entire directory at which point FreePBX will say the module is broken. (haven’t done this in a while so I may be mistaken). You can then tell Module Admin to remove it and then go get it again and install it.

If that does not work, you can delete the entry in the modules table and the reinstall it. If the ivr tables are in there you should probably delete them as well.

However, you may want to check with the FreePBX paid support team to have a look at this and your other issues to see if there are any serious problems with your install. Then send the invoice to your “paid consultant” who seems to have left you on your own.

Thanks so much for your help, Philippe. I just removed the whole ivr directory again and module admin said not installed. Then I selected download and install from module admin, I got the same error:

"Downloading ivr

ALTER TABLE ivr CHANGE COLUMN announcement announcement VARCHAR ( 255 ) [nativecode=1054 ** Unknown column ‘announcement’ in ‘ivr’]"

Actually, before I upgraded, everything else was working, except the *65 reported wrong extension – all analog phones reported same extension number, even they were not, and can call each other and working in the queues correctly.

In the installation, I did not have “announcement” configured. Could that be the cause for the problem – does that new update require all the fields existed for successful update?

How to delete the entry in the modules table? and how to reinstall it. I think the ivr table is there in the database. My database actually have more than just FreePBX using it. So I don’t want to delete anything else by mistake.

My phone system is down now. I need to get that backup running…

I reinstalled the FreePBX 2.7 and now all the errors are gone. Reinstall is not that hard after all. I just dropped two database tables, asterisk and asteriskcdrdb, then removed the /etc/amportal.conf.

From that point, I can do fresh installation. create two database tables, using the install.sql scrrits to initialize those two tables; grant the privileges ; then run the ./install_amp install.

Once FreePBX starts running, I updated and installed modules, no error any more.
However, *65 does not announce the extension number, it just say “your extension number is” then hang up. If anyone knows where to look for that, I would really appreciate it!