FreePBX | Register | Issues | Wiki | Portal | Support

Memory issues after asterisk 15.7.2 update over the weekend


(Jared Busch) #1

Updated two systems over the weekend and both are having the same problems this morning.
Memory is slowly filling up until the system fails to process calls.

Both systems were on Asterisk 15.5.0 and yum updated them to 15.7.2. One system was rebooted afterwards, one was not.

Everything was working fine until a few hours into day usage. Both sites contacted me that their phones were down.

I was only able to get into glances on one of the two systems prior to forced shutdown.

After reboot, both systems came up normal, but swap was used almost immediately. This has not normally been noted.

image
image

After an hour or so, the one system was failing to process calls again.

I reverted that one to the VM backup made right before the updates (so back on 15.5.0).
After almost 30 minutes it still has no swap used and I expect no issues.

The second system is still on 15.7.2 but memory use is growing. It was 39% in that screenshot above.


(Jared Busch) #2

hours later, both systems still running smooth back on 15.5.0.


image


image


(Andrew Nagy) #3

Switch to asterisk 16 since it’s an LTS


(Jared Busch) #4

I can test that this weekend, but that doesn’t mean there is not a potential issue.


(Tom Ray) #5

If there is a potential issue then it needs to exist in 13 or 16 because those are LTS. 15 is SFO and 15.7.2 was an SFO update.


(Travis) #6

Similar issue here. Update went from 15.5.0 to 15.7.2 and afterwards Asterisk started hanging throughout the day. Had to restart Asterisk service to resolve. I did a downgrade to 15.5.0 and it seems to be back to normal.

Tried moving to 16 while I was troubleshooting, but wasn’t able to get Asterisk to start at all after switching versions. Will have to look into that when I have time to take down the server.


(Itzik) #7

Hmm… That’s strange, how did you switch version?

Using asterisk-version-switch command?


(Travis) #8

Yep, just used asterisk-version-switch. After it did it’s think, Asterisk wouldn’t load at all. Tried to restart it a few times, didn’t look to closely. Just used the same command again to go back to 15.

Update: The issue I was having is mentioned in the thread below, the fix resolved my issue and I was able to move to Asterisk 16


(Jared Busch) #9

I have never had that happen. Since reporting this, I have switched one low use production system and one system currently being setup from Asterisk 15.5.0 to 16.2.1. Obviously not valid tests, but after having no phones multiple times on Monday, at two sites, I’m not going to switch those until Friday night.


(Cassseus) #10

I had the same exact issue after Yum upgrading from 15.5 to 15.7.2 over the weekend.
Since I have people who depend on that box, I rolled back to 15.5.

If you read the release notes, you’ll see that they applied the same security fixes in 15.7.2 as they did in 16.2.1


(Andrew Nagy) #11

Not relevant. The code bases are different.


(Mulderlr) #12

I can also confirm asterisk 15.7.2 hangs for me as well. Rolled back to 15.5.0 for now, but will attempt to upgrade to 16.2.x soon.


(Jared Busch) #13

Upgraded those two systems to 16 last night.

So far everything is normal this morning.


#14

Upgraded from asterisk 14 to asterisk 15 yesterday night, phone system went down (not even internal calls worked) about 12-13 hours after that. I’ve now switched to asterisk 16. Was perfectly stable on 14 before.
(Running FreePBX 14 on FreePBX Distro 7)


(Andrew Nagy) #16

@Benn5325 don’t hijack this thread. Start a new one with your unrelated issues


(Jared Busch) #17

So the answer to upgrade to 16 is problematic if you also use FOP2.

There are two instances in the FOP2 modifications that reference a depreciated function name that was finally removed in 16. That can be worked around manually.

So anyone with 15.7.2 and not wanting to move to 16, needs to use yum downgrade asterisk15*

Anyone that moves to 16 and also uses FOP2 needs to modify /etc/asterisk/extensions_override_fop2.conf


(Lorne Gaetz) #18

Since 15 is security fixes only now, I would recommend switching to 13 instead of downgrading 15.


(Jared Busch) #19

I have not used 13 in quite a while, and have no idea how stable it is. So I cannot recommend something I do not know. I know 15.5.0 was stable and so have been both versions of 16 I have used (16.0.0 and 16.2.1).

I would expect current 13 is likely stable, yes. Just I have not used it.


(Tom Ray) #20

It’s LTS just like 16 is LTS. There is always that space of time when there are no Stable releases of Asterisk just two LTS releases. Asterisk 13 gets support and fixes until 2020 due to there being two Stable releases in a row (14 and 15) one was EOL’d in 2017 and the latter is SFO and due to be EOL this year. The only reason there is a 15.7.2 was due to a security flaw found in older versions of 15.x and it was updated since it’s still SFO.

15 hasn’t gotten any other fixes or updates since Oct 2018 while 13 and 16 continually have.


(system) closed #21

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.