Memory consistently grows over several days until system stops processing calls - need help with cron job

Hello - this is related to a recent post I made here - Asterisk dies after odd error messages related to voice queue length . This issue still happens with this box. I have tried to watch top and check what is happening, but it happens very slowly over several days. I only see mysql, asterisk, and other normal things popping to the top of the list. Looks normal to me. If we restart asterisk (no need to restart the machine, its physical BTW) everything is fine for the day at least. I tried to setup a cron job to just restart asterisk at 3am figuring some future update will fix this problem - but I cant get the cron job to run. I first tried to set it up under the asterisk cron jobs. Then I tried under root… The line Im using in these cron jobs is -
0 3 * * * /var/lib/asterisk/bin/fwconsole restart

When put into the root - its the only thing in the list. When put into Asterisk - this is the entire file if it helps point to why it isnt working…

I dont think we can resolve the memory issue altogether (Im going to give the client the option to build their backup box and move the backup over to see if its hardware/software) but in the meantime Id like to get this cron job working so we dont have to remote in every morning and do this manually.


0 3 * * * /usr/sbin/fwconsole restart

but perhaps better, try a different version of asterisk?

What version of FreePBX is this and why are you relying on cron jobs?

This is a brand new distro FreePBX built less than 2 months ago. It has all the latest patches and updates. This has been happening since around the time he purchased the commercial queues module - although I cant be exactly sure that is related. We first noticed the web interface became very slow. then a few days later it stopped processing calls - with the errors in the log I referenced in the other thread. the only thing we notice is the memory slowly creeps up over several days. restarting Asterisk each morning “works around” whatever the memory leak is. I have several other customers with similar hardware and versions with no issues. However - this is my only client using Queues to this extent.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.