MD5 did not match when installing Polycom via Endpoint Configuration Manager

I’m getting:

Downloading Brand XML…Done!
Downloading Brand Package…

Checking MD5sum of Package…MD5 Did not match!

When trying to install the Polycom files for the endpoint configuration manager. The result is that I can’t use the Endpoint Manager to program my Polycom phones. I’ve got to be able to download & install the Polycom files via the Endpoint Manager before I can use it.

Any ideas here?

FYI, my “Package Server” URL is:

Is this correct?

I appreciate help here.


FYI, I tried to change the package server to:

But the resulting error is the same.

Hmm. It’s working today. I uninstalled & reinstalled the Polycom package via the Endpoint Configuration Manager & it downloaded & installed just fine without the MD5 checksum error.

Yes. I fixed it. Sorry for the inconvenience

Did you change something? it worked fine yesterday, working on a new install today and I’m getting the error now, tried all steps above without any luck…

You may be successful by downloading the file directly from:

And then in the Endpoint Configuration Manager there is an advanced option to upload the file directly.

This worked for me yesterday, but I thought it wasn’t working for me, when really the problem was only that I needed to have my Polycom phones on the latest 3.3.x firmware. :slight_smile:

Let us know if this works for you.

No. I have not changed anything and it’s still working 100% from three different machines. Sorry for your troubles. I don’t know what to say.

I am experiencing the same issues trying to “Install Firmware” via the End Point Configuration Manager. I have tried the recommendations above but they don’t seem to work. I keep getting an MD5 doesn’t match error.

I didnt know the firmwares were the problem. Fixed now.

tm1000, thank you for fixing that. It worked but I had to uninstall the EPCM module and reinstall it.


I have just installed my first FreePBX distro, and am having the same MD5 checksum issues indicated by the original poster of this thread.

I have attempted to uninstall and reinstall the main Package (as suggested in another thread) which completes with no errors , and can download the Polycom Firmware but the install does not complete because of the MD5 checksum error.

All of my phones are Polycom. Please let me know if there is something I can do as I am still in the evaluation phase of FreePBX. Thank you, and this interface looks really cool with the Frog :slight_smile:

I get the same error for my Grandstream.

Trying to download the firmware for the current production Polycom and having the same issue. MD5 didn’t match

This is fixed once again.

As always you MUST uninstall the brand and then reinstall it to be able to install firmware.

Thank you very much for correcting the issue.

After uninstalling the brand and then reinstalling the brand, the Polycom Firmware package installed with no issues.

Thanks again for the quick response!

I am having a similar issue. I cant get any modules to install. Both manually or automatically. I have tried to change the package server to everything above but I still get:

Not able to connect to repository. Using local master file instead.

Aborting Brand Downloads. Can’t Get Master File, Assuming Timeout Issues!

Learn how to manually upload packages here (it’s easy!): Click Here!

when I install packages manually, they dont upload, though I dont get an error. When I do the polycom file, I get an error that the file is too large. Any Ideas???