Maxsilence in VM Options doesn't seem to work

I added maxsilence=20 in VM options under an extension. It doesn’t seem to do anything, as the phone call is cut off about 3 seconds after silence happens. I’d like to increase that to 20 seconds for a particular extension. How could I make it happen?
I’m using FreePBX

Realize that many phones also have silence detection. So it’s totally possible that the phone silence detection is kicking in and not the voice mail detection.

The same thing happens when calling from two different cell phones, and from a local SIP extension phone (Polycom 500).

This is not a per-user option on asterisk 1.2 or 1.4. Even though it is not clearly documented, maxsilence must be specified in the [general] context of voicemail.conf as a global setting for all voicemail users. If it is added as a user option, it will be ignored, but will not cause an error. I do not know if asterisk 1.6 works the same or not.

As far as I am aware, FreePBX does not include maxsilence on the General Settings page, so you would need to edit the voicemail.conf file directly, then reload for your changes to take effect.