Max Message Silence default value (10ms instead of 10sec)

In Voicemail module, the default value for Max Message Silence used to be 10 seconds

Voicemail module version

On some systems, after updating the voicemail module, this value seems to have switched to milliseconds, but the value is still at 10 (should’ve been 10000)

Voicemail module version

I noticed this when users started reporting that a lot of their voicemail was missing the end of the message.

I will change this value to the max (9999) to fix the issue but I would like to know if the 10 milliseconds default value is a wanted value or is it a bug ?

10 milliseconds is directly from the default Asterisk value for this. So it’s not a bug but is the default value.


Any reason why it went from 10 seconds to 10 milliseconds ? (if it’s on Asterisk’s side, I know it’s not your decision)

It was milliseconds for a long time but it’s documented incorrectly in their documentation until you go look at the actual source code where they treat it as milliseconds. I haven’t got around to updating the documentation as others havent either in Asterisk. Its the only setting that is in milliseconds.

It also show as seconds in the logs: Recording automatically stopped after a silence of 10 seconds

Anyway, I’ll just change the value to 9999 to fix the issue. 10ms of silence is waaayyyy to fast ! The voicemail recording sometimes stops between 2 words.

If you want more history about the setting look through this ticket.

I provide the code stack from Asterisk where it’s milliseconds.