Mass password update for iSymphony extensions and disabling it all together?

From my understanding there only 1 license is provided with iSymphony. I did some testing for a new deployment and like the idea but it does not seem to be totally working.

  • When putting a call on hold it hangs up on my end but leaves the user on hold.
  • Queues do not show up
  • Clicking the voicemail on someone else extension rings my phone then hangs up (auto-answer enabled)

I did a bulk extension import and as such all of the passwords have been defaulted to secret. Is there a way to mass update these?

Is it possible to disable iSymphony to reduce security risks.

When doing a mass import of data into FreePBX the iSymphony module is not aware of the modifications being made to the system. In this case the best option is to uninstall then re-install the module after the import is complete so that the module can refresh itself with the new data.

If I uninstall/reinstall the module will it be in the same operating state from a fresh FreePBX distro install in the sense of configuration?

Is it true that with the version included in the FreePBX distro that only 1 user can use it at a time and additional licenses are required for additional users?

Here is the document on the differences between the free and Conductor versions.

iSymphony is not Open Source, it is commercial. The Free Edition is offered in the distro as an optional package.

http://www.getisymphony.com/compare-features/

I see they now have a monthly model.

Thanks Skyking

mwolf9 I am able to uninstall the module successfully, however when I try to apply the configuration it does not work, would you be able to advise on how to remove it successfully?

Please wait while module actions are performed
Restoring operator panel web root to default…
Removing client symlink…
Removing “isymphony_location” Table…
Removing “isymphony_users” Table…
Removing “isymphony_queues” Table…
Removing “isymphony_conference_rooms” Table…
Removing manager entry…
isymphony uninstalled successfully

Reload failed because retrieve_conf encountered an error: 1

exit: 1
found language dir fr for directory, not installed on system, skipping
[FATAL] SELECT * FROM isymphony_location [nativecode=1146 ** Table ‘asterisk.isymphony_location’ doesn’t exist]SQL -
SELECT * FROM isymphony_location

Trace Back:

/var/www/html/admin/libraries/sql.functions.php:11 die_freepbx()
[0]: SELECT * FROM isymphony_location [nativecode=1146 ** Table ‘asterisk.isymphony_location’ doesn’t exist]SQL -
SELECT * FROM isymphony_location

/var/www/html/admin/modules/isymphony/functions.inc.php:325 sql()
[0]: SELECT * FROM isymphony_location
[1]: getRow
[2]: 2

/var/www/html/admin/modules/isymphony/functions.inc.php:138 isymphony_location_get()

/var/lib/asterisk/bin/retrieve_conf:646 isymphony_get_config()
[0]: asterisk

1 error(s) occurred, you should view the notification log on the dashboard or main screen to check for more details.

Do you get the same results in the log each time you tried a reload in FreePBX? How exactly did you remove the module? It looks as if the module database tables were removed but the module itself was not removed form the FreePBX module registry. Not sure if this was a one time thing due to the module sill being registered in the system on the reload after un-instillation. One thing you can try is to remove the module from the system by deleting the following folder:

/var/www/html/admin/modules/isymphony

Reload the module page and FreePBX should notice that it is gone and mark it as broken. Once cleared you can download the module installer at

www.getisymphony.com

and re-upload and install.

I do get the same error message if I try it multiple times. I also have a QA server that is running the same FreePBX distro and the same thing occurs on that one. The process I am using to remove the module is by going to module admin and uninstalling isymphony.

I just deleted that folder from my QA server which allowed me to apply the changes. When I go back to the module admin and check online it does not show up which is interesting, I would think it would find it in the repo?

chkconfig still has iSymphonyServer and the files are still in /opt/isymphony. When I try and stop it using the shutdown.sh it says there is no such file iSymphonyServer.pid but when I start it it seems to work as it says daemonizing. Do you know the best way to remove all files/services/MySQL references?