Manager.c:2675 authenticate: failed to authenticate as 'admin'


My logs are being flooded with this error message… I have double checked the the admin password under amportal.conf and manager.conf are correct, as is the password under advanced settings.

Anyone have any other suggestions on where I should be looking to correct this? I saw a previous post mentioning that FOP2 connecting could be causing this, and I DO have FOP2 installed.

Any input would be appreciated!


Bump. Any ideas? I’ve checked that fop2.cfg has the correct AMP password as well…

This is a “permit/deny” error. Your manager.conf (or whatever authentication source you are using) doesn’t have “[admin]” being allowed from I’m going to guess you “tightened up” security by replacing with your local network address instead of adding it.

Hi Dave

Thanks for the reply… here is the output from manager.conf

secret = *******

I didn’t make any changes there… the only thing I did to tighten security up since this box is available over the internet was I changed the web port to 50000

Any other ideas?

OK, then.

Assuming you are using config files for your manager settings (and not the database), try this:

  • Log into the console as ‘root’.
  • cd /etc/asterisk
  • grep ‘admin’ *manager*conf

There might be two files that define admin - if that’s the case, the system will use the last one it reads (IIRC). Also, there should be more to that error message. The rest of the line should define exactly which error it’s seeing.

When I perform that command my output is only [admin]

That is the full error message I’m seeing in my logs though:
[2016-06-13 11:29:36] NOTICE[8342]: manager.c:2675 authenticate: failed to authenticate as ‘admin’


I updated the ‘grep’ to include ‘*’ characters (an important part of the process - sorry).

If there’s only one “[admin]” section in all of the manager config files, then your problem is probably a bad password. Something in your system is either using the default password (or an old password). There are lots of things in the system that use the ‘admin’ user to connect to the system. The trouble you are going to run into is finding out which one it is.

For the systems I set up, I usually leave the admin user for automated updates (the FreePBX portal page, for example) and use a different username (maint, historically) for interactive access to the server.

I’d start with the /etc/amportal.conf file and make sure the admin password in there matches the one in the manager.conf file.

If that one matches, enter the commands from the previous message and change the grep to something like this:

grep -l admin /etc/asterisk/*

That will give you a list of all of the files in the Asterisk directory that have the ‘admin’ username, plus several that are completely unrelated to your problem.

Once you’ve ruled out those sources, it’s time to get more creative. In a “distro” system, you can look in /var/www/html/admin/ and search through there. Note that almost everything in this directory is managed by FreePBX, so there will be a setting in the GUI somewhere to match these entries.

Not sure what it was, but I just upgraded to FreePBX13 and that resolved whatever the problem was.

I’m pretty sure it has something to do with FOP2 though because that was the only difference between this install and my other working install.

Thanks for the help Dave.