Manager.c: 127.0.0.1 failed to authenticate as 'admin'

Hello, I have setup my trixbox 2.6 and been enjoying it. started setting passwords to lock it down a bit, edited /etc/amportal.conf and started mucking around, ran into a few snags and fixed most of them via google.

There is only one remaining that i’am aware of, everything seems to function in http://myserver.com/maint/index.php except for http://myserver.com/maint/index.php?astInfo

When I click on it, the page just sits there refreshing, blank where the info should be. so, i think first off, maybe it can’t the password changes i made are not being taken by whatever astInfo uses, i looked at classes etc etc. could not track down where to set the pass for admin that astInfo can now use the new password.

Here are logs i could gather, please inform me if you need more.

[trix.dawnshosting.com asterisk]# tail /var/log/asterisk/full
[Nov 3 19:28:56] VERBOSE[5809] logger.c: == Parsing ‘/etc/asterisk/manager_custom.conf’: [Nov 3 19:28:56] VERBOSE[5809] logger.c: Found
[Nov 3 19:28:56] VERBOSE[5809] logger.c: == Manager ‘admin’ logged on from 127.0.0.1
[Nov 3 19:29:02] VERBOSE[5809] logger.c: == Manager ‘admin’ logged off from 127.0.0.1
[Nov 3 19:29:12] VERBOSE[5486] logger.c: – Remote UNIX connection
[Nov 3 19:29:19] VERBOSE[6019] logger.c: == Parsing ‘/etc/asterisk/manager.conf’: [Nov 3 19:29:19] VERBOSE[6019] logger.c: Found
[Nov 3 19:29:19] VERBOSE[6019] logger.c: == Parsing ‘/etc/asterisk/manager_additional.conf’: [Nov 3 19:29:19] VERBOSE[6019] logger.c: Found
[Nov 3 19:29:19] VERBOSE[6019] logger.c: == Parsing ‘/etc/asterisk/manager_custom.conf’: [Nov 3 19:29:19] VERBOSE[6019] logger.c: Found
[Nov 3 19:29:19] NOTICE[6019] manager.c: 127.0.0.1 failed to authenticate as ‘admin’
[Nov 3 19:29:20] VERBOSE[6019] logger.c: == Connect attempt from ‘127.0.0.1’ unable to authenticate
[Nov 3 19:29:26] VERBOSE[6017] logger.c: – Remote UNIX connection disconnected
[trix.dawnshosting.com asterisk]#

Verbosity is at least 3
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Connect attempt from ‘127.0.0.1’ unable to authenticate
trix*CLI>

Oh boy trixbox…

There is a proper way to change passwords. The way for trixbox is to use the passwd-maint, passwd-amp, passwd-meetme, etc. scripts…

You’ll find what you need if you type help-trixbox.

Editing files and just changing things doesn’t work as some places need to be all updated at the same time. MySQL for example, needs a change in MySQL and in the config files.

See, I thought that too, but they must have removed all but passwd-maint

Trixbox 2.6 shows this

Commands Descriptions

system-config-network configure ethernet interface
passwd-maint set master password for web GUI
passwd set root password for console login
setup-cisco create a SIPDefault.cnf in /tftpboot
setup-aastra create a aastra.cfg in /tftpboot
setup-grandstream setup for autoconfiguration of Grandstream
setup-linksys setup for configuration of Linksys phones
setup-polycom setup for polycom phones
setup-snom setup for snom phones
setup-dhcp set up a dhcp server
setup-samba set up a Samba server (Microsoft file sharing)
setup-mail configure sendmail
setup-pstn detect and setup supported PSTN interface cards
asterisk -r Asterisk CLI
install-hudlite Install hudlite server
install-postfix Install postfix mail server
install-sendmail Install sendmail mail server

Check that the password for [admin] in manager.conf and AMPMGRPASS in /etc/amportal.conf are the same

update user set password = PASSWORD(‘yourpassword’) where User = ‘asteriskuser’;
grant all privileges on . to [email protected] identified by ‘yourpassword’ with grant option;
grant all privileges on meetme.* to [email protected];
grant all privileges on endpoints.* to [email protected];
grant all privileges on asteriskrealtime.* to [email protected];
grant all privileges on asteriskcdrdb.* to [email protected];
grant all privileges on asterisk.* to [email protected];
flush privileges;

vi /etc/asterisk/manager.conf
secret = yourpassword

vi /etc/amportal.conf
AMPDBPASS=yourpassword
AMPMGRPASS=yourpassword

Harvey Jarquin.
AUTHTYPE=database
AMPDBPASS=yourpassword

vi /etc/asterisk/cbmysql.conf
password=yourpassword

vi /var/www/html/web-meetme/lib/database.php
$password = ‘yourpassword’;

vi /etc/asterisk/cdr_mysql.conf
password = yourpassword

vi /etc/asterisk/cdr_mysql.conf
password = yourpassword

vi /etc/trixbox/httpdconf/trixbox.conf

#Password protect /var/www/html/admin
#<Directory /var/www/html/admin>
#AuthType Basic
#AuthName "Restricted Area"
#AuthUserFile /usr/local/apache/passwd/wwwpasswd
#Require user wwwadmin maint
#</Directory>

#Password protect /var/www/html/maint
#<Directory /var/www/html/maint>
#AuthType Basic
#AuthName "Restricted Area"
#AuthUserFile /usr/local/apache/passwd/wwwpasswd
#Require user maint
#</Directory>

vi /etc/asterisk/extensions_additional.conf
AMPMGRPASS = yourpassword

churrodivx,

While I do understand you are attempting to help some of the information you provided is incorrect.

  1. You are at least missing one step to reload the system so it reads the config files new values and uses them.
  2. You can NOT EDIT extensions_additional.conf See http://freepbx.org/configuration_files.
  3. You also don’t state for which version of FreePBX in trixbox this is for (if it’s 2.4 or higher it says to not edit the extensions_additional.conf file at the top of the file as it’s regenerated each and every time to apply changes).

Fonality likes to change the game from version to version (and without notice) so while these directions might have worked for you (except for the changing of extensions_additional.conf) they will not help many without including those other details.