Lost trunk connection

siptrunk
freepbx
configuration
Tags: #<Tag:0x00007f7029a8a0e8> #<Tag:0x00007f7029a89eb8> #<Tag:0x00007f7029a89d50>

(United States) #21

It is consistant. Three calls all have the same Called PJSIP followed by Everyone is busy.
Is “Everyone is busy” generic message for the trunk is not available?


(United States) #22

What does this tell you? All outbound call attempts get ACB and a log like the example here.

[2020-07-23 12:26:03] VERBOSE[2295][C-00000021] app_dial.c: Called PJSIP/3034640033@F1Systems

[2020-07-23 12:26:03] VERBOSE[2295][C-00000021] app_dial.c: Everyone is busy/congested at this time (1:0/0/1)


#23

No matter how you slice/dice it line 180 says that the carrier will not complete the call but not the reason why, use ‘sngrep’ to see if that makes more sense as it decodes the sip session into a semi human readable form


(United States) #24

sngrep shows that the calls are rejected. Not seeing why. pcap.tgz (20 KB)


#25

send that pcap file to the vendor and let them tell you


#26

The INVITE you sent to Flowroute contains:

INVITE sip:3034640020@us-west-or.sip.flowroute.com SIP/2.0
Via: SIP/2.0/UDP 173.160.51.229:5060;rport;branch=z9hG4bKPjf8c28969-f1b0-4639-8550-dda2f1859292
From: <sip:204@192.168.1.244>;tag=493a9fd7-1b21-4367-b2ce-30b360523e80
To: <sip:3034640020@us-west-or.sip.flowroute.com>

There are at least two things wrong. The destination number must be in the form 12345678*13034640020 where 12345678 is your tech prefix; otherwise it looks like a call to Greece (country code 30) and with no auth. The call got a 403 Forbidden error.

Also, the From number must be a valid caller ID; e.g. 1304640011.


(United States) #27

Yes, this indicates that IP Authorization is not getting my techID prepended to the call. I have the TechID in the Dial Number Manipulation Rules as it has been all this time.

It looks to me like my IP Auth settings are correct. If so, then what?

Dial Number Manipulation Rules

pjsip Settings

General


#28

In the Dialed Number Manipulation Rules, the section with prepend, prefix, match pattern should normally all be blank. However, if you dial domestic calls as 10 digits and you have other trunks that accept that, you could put prepend 1 prefix (leave blank) match pattern NXXNXXXXXX
which would put in the initial 1. Otherwise, your Outbound Route is a better place to prepend the 1.

Then, in any case, set Outbound Dial Prefix to your tech prefix followed by * e.g. 12345678*

If this is done correctly, the outbound INVITE should look like
INVITE sip:12345678*13034640020@us-west-or.sip.flowroute.com SIP/2.0


(United States) #29

Vendor mail system won’t accept pcap file in an email. (did just get it sent)

It seems clear that the TechID is not being passed to to the trunk. I have all the settings per the tutorials from freepbx and flowroute. Here are the screen shots. I have restarted the system after these settings were made (fwconsole restart). Here are screenshots.

https://community.freepbx.org/uploads/default/original/3X/6/7/67dbe87544beae2cc52c8234612735a93405f9d2.png
https://community.freepbx.org/uploads/default/original/3X/e/3/e3034ff9489411cc1097c2a26c57a0da1e06ee61.png
https://community.freepbx.org/uploads/default/original/3X/5/e/5ec6c0042750f8ab2e8036889f52142143f2984f.png


#30

You need to prepend not prefix your tech number


(United States) #31

image

DOH! I had not put it in the Oubound Dial Prefix. Dicko, I can not thank you enough for hanging in there with me.


(United States) #32

DickO pointed out that it is a Dialing Prefix where I had the techID in the Prepend field.

image

DOH! I had not put it in the Oubound Dial Prefix. Stewart1, I can not thank you enough for hanging in there with me.


#33

But two hours ago I posted exactly that:


#34

On Flowroute, it’s better to submit a support ticket. https://support.flowroute.com/submit_ticket
On the form, there is a little paper clip just below the Message box. Click it and you can attach any kind of file you like.


#35

My guess is your codec. You are using g722. Is your voip provider setup to accept calls for the g722 codec? Some providers don’t have this available or it needs to be enabled in your provider settings.


#36

Change Match(Permit): from “147.75.60.160/28, 34.210.91.112/28, 34.226.36.32/28, 147.75.65.192/28” to “147.75.60.160/28,34.210.91.112/28,34.226.36.32/28,147.75.65.192/28”

Some update is no longer parsing the whitespace in that field.