Lost audio when I set External Address in Sip Settings -> General Sip Settings


#1

I’ve had a system that’s been working well for years. I currently have the server and extensions behind a firewall. Using PJSIP to connect to vitality for my trunk via a register string.

Given the recent circumstances, I’d like to add an extension outside of our network.

I’ve added the PJSIP / RTP port forwards to my firewall (were not there before).

I tried the new extension outside the network and there was no audio.

So, I started looking around, and noticed that there was nothing set in External Address in the General Sip sessions tab. So, I put in my external IP address and applied changes.

After that change, my external phone would no longer dial & all of my internal extensions & the trunk lost audio. I did add my 3 internal /24 network ranges.

I know there was a Wiki around for audio issues, but I can’t find it now. Pointers to the wiki or other tips?

I’ve ordered a s406 phone so I can just switch to VPN, but I’d like to understand what is going on with regard to pjsip and the external address. Currently using paid EPM and Polycom phone (I have a mix of s405 and Polycom).


#2

After changing External Address or Local Networks, you must restart (not just reload) Asterisk.

Make sure that Rewrite Contact is Yes for the external extension (it’s also ok for the internal ones).

For both an internal and an external extension, try to find the simplest thing that fails. For example, if *43 (echo test) doesn’t work, use that to debug. Or, try a call to your own mobile (so you can tell whether outbound audio is working, as well as inbound).

At the Asterisk command prompt, type
pjsip set logger on
make a failing test call, paste the relevant section of the Asterisk log at https://pastebin.freepbx.org and post the link here.


#3

Thank you! I’ll update and restart and see what it does. I’ve been trying the *45

Is there anything that documents the difference between the external server setting in the general, pjsip, and sip setting tabs? I did notice that the SIP tab had a setting for dynamic IP.

Was going to try different settings and look at the /etc/asterisk conf files, but going to spin up a spare server to do the experiments.

Also, I can use a FQDN for the external server or does it need to be an IP address?


#4

Unless you changed the feature code, echo test is *43.

From what you’ve told us so far, just enter Local Networks and External Address in Asterisk SIP Settings and leave the overrides in the pjsip and sip sections blank.

You can use an FQDN but for testing, don’t push your luck; enter the IP address so you don’t have to worry about how often the name is looked up.


#5

Thank you.

By “*45” testing, the only reason I mentioned that is because that’s where I noticed the problem. I was excited to see the phone could call my cell. Then I needed it to participate in a queue, but I didn’t get the normal voice response to the *45. I will use *43 when I go back to the remote location today.


(Dave Burgess) #6

Local audio problems are usually related to the local network (especially on a VPN) not being correctly identified in the SIP settings.

While the Integrated Firewall is supposed to take all of that into account, I “belt and suspender” the firewall by making sure the local addresses are correctly identified in there.

If the phone can register and/or dial, the “basic” SIP port (usually 5060, but varies based on configuration choices and channel driver you’re using) is connected and is routing correctly. Pure audio problems, when caused by the network, are because of UDP 10000-20000 not being correctly routed/configured.


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.