Lost 3 way calling ability after update?

my setup:
Asterisk Version: 13.14.0
phone: grandstream gs2170

after upgrading we noticed that the 3 way calling stoped working, doing like we always did:
make a call
press the conf button, the dial screen apear
dial the number
(click dial) this is where normaly the other call get placed now it just drop back to the on hold call

the only change was the updates of the system, so my guess is some config are now not working or need new configuration to comply with the updated system.

i did look around and tryed the few solution i found on that subject but no success, any suggestion or we are dommed to reinstall everything?

thx for your time

Sounds like your using the built in conferencing that’s on the phone. You prob updated your phones firmware that is causing your issue.

thx for the awnser, i just tryed downgrading the firmware and the issue is still the same :frowning:

looking at the verbose log i can see the call part and the hangup part but nothing for the 3 way attempt as if the phone tryed nothing…

This would be a phone issue as the phone does the dual and the mixing of the audio not asterisk when using conf button on the phone.

so there is no configuration in asterisk that tell the phone how to handle this ect? i tryed all the phone firmware version avaible on theire website and still the same, i would of got some result if this was a phone/firmware issue, as it already worked fine beafor.

For those that get a similar issue here the solution i found
Phone only had 1 key configured as line, trying to edit it in the phone config worked but were getting overwrited at reboot by the pbx config.

in freepbx go to
setting-> Endpoint Manager -> (your brand template)
click on your phone model
edit the keys setting so at least 2 of them have “line” selected
save model
save and rebuild config
reboot your phone

1 Like

I had a issue when the system pushed the firmware to the GXP-2170. Same issue where I could only open 1 line as I before could open as many as I had buttons. I have to downgrade the firmware and factory rest the phone to get them back. Rolled back to

yes, you could set each VKM to a line operation, but them you have a very cluttered screen with the same Ext on all lines showing.

Good to know

on my side i had a free button and to avoid seeing the local name on the line i made it belong to an unused account number, the 3 way still work and the vkm show as empty but they serve as holder for opened lines.

hopefully they will change this back in future updates

I noticed the conference method for those phones changed with the newest update.

Here is what I did that seemed to work:

  1. Call someone
  2. Press the conference button with the 3 people
  3. Dial the 3rd person’s number
  4. When they answer hit the “confCall” button below the screen
  5. It will then merge the 3 calls.
1 Like

Hi adtopkek,

I have the same issue, mind you asking which firmware are you using? (I don’t see “confCall” button on mine. I am using ver. of firmware, are you using beta release?)

I see, I got that to work, in order for the conference call to work, VPK needed to be configured as “line” by selecting “Default” in the Mode field. (I am in a learning curve, lots to learn…)

1 Like

I’m using a GXP-2160

After step 3 for me I see on the horizontal buttons on the bottom of the lcd: “EndCall” “ConfCall” “Transfer” " " “Hide label”. When I press that the two calls merge.

I have 2 defaults/lines. I guess you need at least 2 defaults/lines for the conference to work.

There is a lot to learn with all of this @_@. I keep fixing one problem only to have another problem pop up because a different brand doesn’t like what I did.

1 Like