Long wait on Outbound calls using SPA112

So my setup is like this:
Cisco SPA112 connected to a FreePBX server which is connected to a SIP trunk from Thinktel.
When connecting a generic analog phone to the SPA and trying to make an outbound call, it takes at least 10 seconds before it starts to ring.

I also have SIP phones on the network connecting to the same PBX and they do not have this issue. Is there maybe a setting in the SPA’s that need to be changed or is there something in the PBX?

Tell the user to press # after dialling the number.

No other options hey? This is for a seniors home and trying to get them to do something “new” is very difficult. :frowning:

It’s likely your “dial string”

It needs to match the various destinatopns (both phone numbers and feature codes) that could be called from from the ata’s

Hello @Laveniuk ,

Reduce your interdigit timeout from 10 seconds (the default) to 1 second.
Here is the process:

Step 1.
Log in to the Phone Adapter Configuration Utility and choose Voice > Regional.
The Regional page opens:

Step 2.
Enter the value 1 for the Interdigit Long Timer field.

Step 3.
Enter the value 1 for the Interdigit Short Timer field.

Thank you,

Daniel Friedman
Trixton LTD.

Be careful of setting the interdigit timeout to 1 second, as teaching the senior citizens to dial “really quickly” will likely not work so well either. However setting the dial string to cover all likely calls preempts the need to wait for “timeout” whethere it is 10 or 1 second or the need for a terminating #

Which country are we talking of here? we can possibly come up with a “closed” dialstring to suit.

1 Like

What if i change that Interdigit to say 3.
Because you are saying that setting it to 1 will make them have to dial very fast?

I am in Canada.

Do you use 10 or 11 digit dialing ?
Are 7 digit calls allowed ?
Are international calls (non NANP) allowed ?
How long are your local extentions and of what pattern
Can your clients call 0, 911 or any other “short codes” ?

10 digit dialing,
No 7 digit dialing.
local extensions are all 3 digits long. and go anywhere from 101 to 899
No international calls.
They cannot call zero, but they can call 911.

[*#]XX (matches feature codes
|911 (matches 911)
|NXXNXXXXXX ( matches all external calls)
|[1-8]XX ( matches all extensions)

so try

The local extensions not starting with 1 collide wiith the regular calls so if they mostly call externally then you will need to wait longtimeout to have any internal extension that does not start with 1 ring, using 11 digit dalling avoids that of you dont use 1xx for you extensions , alternatively stay wirth 10 digit dialing and limit all extensions to ^1X. , if you need more that 100 , then use 4 digit extensions