Long Distance Dialing Ends in Quick Busy


(Pbx Newbee) #1

I am using the current version of FreePBX with a Sangoma S705 with a Vega 60G GW interface to POTS lines. When I try to dial long distance, and only long distance, the phone will pause and eventually have a quick busy signal and not dial the number. It will take several times to eventually dial the number. This occurs almost every time that I dial long distance and it can take 4-5 tries before the number will actually dial. I tried uploading the log file but I’m not sure where to start and the portion that I tried to upload is too large. Happy to upload if someone can help me limit to what would be important. Thanks for any help.


(Jared Busch) #2

Start with this.
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(Aaron) #3

Sounds like a dial plan issue. Does it happen if you dial 10 and 11 digits both?


#4

It’s odd that the call actually works in some cases, assuming you’re redialing the same number every try. How may POTS lines are being used through the vega? If multiple, do you have any problems making a test call to the same long distance destination when connecting an analog phone directly for each line? I agree that this is likely a dial plan issue, but it is interesting that some calls work.


(Pbx Newbee) #5

Thanks. I can get the log no problem I just don’t know which portions to upload. The section that starts when I dial through the end of that portion of the session is too large to upload.


(Pbx Newbee) #6

Thanks. Only with 11 digits. I haven’t had it at all with 10.


(Pbx Newbee) #7

I am redialing the same number. In some cases I simply hit redial. Some cases I manually dial the number again. I have 4 POTS lines. There is not a problem with a test call through the lines from an analog phone plugged directly into the POTS line. There is also a line available. Although I have 4 lines, I only have 2 people in the office and not a lot of incoming traffic.


(Aaron) #8

Most dial plans have a timeout. Like S0 on cisco atas. If you dial fast enough you skip the timeout. Dial too slow…fast busy. Sounds like he has a 10digit fast dial plan somewhere. Timing out after 1 second of a 10 digit dial.


(Aaron) #9

If it doesnt happen with 10 digits then its in your dial plan. So you gotta share all of those. I dont know vegas but dial plans I can read. Also dial plan for sangoma phone and your outbound routes.


(Pbx Newbee) #10

I only have one dial plan associated with one outbound route. Here is the dial plan

prepend prefix match pattern callerid
1800NXXXXXX
1833NXXXXXX
1844NXXXXXX
1855NXXXXXX
1866NXXXXXX
1877NXXXXXX
1888NXXXXXX
1NXXNXXXXXX
211
311
411
511
611
711
911
933
NXXNXXXXXX
NXXXXXX
1 911
9 911
91 911

(Jared Busch) #11

From the description, that’s not what he was talking about. He was taking about the pattern match the phone uses to dial immediately.
In the Endpoint Manager, for Sangoma phones it is this.

Yealink phones look like this in the EPM

Yealink looks like this in a config file
image

These dial plans are what tell the PHONE to begin the actual dial to the PBX. SIP does not send live digits with each button press.


(Jared Busch) #12

That can be simplified as this, along with some comments/questions.

1NXXNXXXXXX # Can your provider handle a call with a 1?
N11
933
NXXNXXXXXX # Can your provider handle a call without a 1?
NXXXXXX # Can your provider prepend an area code and a 1? 

The extra 911 options are not required, but a good call to keep because users


(Aaron) #13

Sangoma dial plan and the vega dial plan if any need to post those too.


(Dave Burgess) #14

Fast busy or 120-busy signals, in the US anyway, are normally reserved for Interconnect Circuit busy. Check wit your provider and look in the /var/log/asterisk/full log to see what is being reported to the PBX server.


(system) closed #15

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.