Long delay between busy extension is detected and the caller from outside hearing the busy tone

there is a problem in FreePBX 2.8.1.4 when i disable my call waiting for a specific extension.
When the extension that call waiting is disabled for that,is busy if i call it from another extension busy tone will hear immediately but if i dial it from outside (telco) i will hear silence for about 15 seconds and then i will get the busy tone.
Here is the log:

[Jun 16 13:40:47] VERBOSE[26508] sig_pri.c: – Accepting call from ‘XXXXXXX’ to ‘1234’ on channel 0/6, span 2
[Jun 16 13:40:47] VERBOSE[10516] pbx.c: – Executing [1234@from-pstn:1] Macro(“DAHDI/i2/XXXXXXX-104ef”, “exten-vm,novm,1234”) in new stack
[Jun 16 13:40:47] VERBOSE[10516] pbx.c: – Executing [s@macro-exten-vm:4] Set(“DAHDI/i2/XXXXXXX-104ef”, “__EXTTOCALL=1234”) in new stack
[Jun 16 13:40:47] VERBOSE[10516] pbx.c: – Executing [s@macro-exten-vm:8] Macro(“DAHDI/i2/XXXXXXX-104ef”, “record-enable,1234,IN”) in new stack
[Jun 16 13:40:47] VERBOSE[10516] pbx.c: – Executing [s@macro-exten-vm:9] Macro(“DAHDI/i2/XXXXXXX-104ef”, “dial-one,”",tr,1234") in new stack
[Jun 16 13:40:47] VERBOSE[10516] pbx.c: – Executing [s@macro-dial-one:1] Set(“DAHDI/i2/XXXXXXX-104ef”, “DEXTEN=1234”) in new stack
[Jun 16 13:41:08] VERBOSE[10516] pbx.c: == Spawn extension (from-pstn, 1234, 1) exited non-zero on ‘DAHDI/i2/XXXXXXX-104ef’

And my chan_dahdi.conf is:
;autogenerated by /usr/sbin/wancfg_dahdi do not hand edit
;autogenrated on 2012-05-20
;Dahdi Channels Configurations
;For detailed Dahdi options, view /etc/asterisk/chan_dahdi.conf.bak

[trunkgroups]

[channels]
context=default
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=yes
relaxdtmf=yes
rxgain=0.0
txgain=0.0
group=1
callgroup=1
pickupgroup=1
immediate=no
pridialplan=local

;Sangoma A108 port 1 [slot:4 bus:14 span:1]
switchtype=euroisdn
context=from-pstn
group=1
echocancel=yes
faxdetect=incoming
signalling=pri_cpe
channel =>1-15,17-31

I guess in DAHDI can not send Busy tone on signaling level to telco.
Any clue?