Long (30 second) pause between hitting dial and and phone actually dialing


(Elvis) #1

Hi, I was hoping for some suggestions on where to go next for this one.

First of all everything else is working ok. Or at least it seems to be.

When I dial a number nothing happens for 30 seconds or so, then the call starts ringing as normal and the call complete fine.

On the asterisk console it just pauses at
– Called PJSIP/0403778788@0735470700 <-- should this be a longer string?

Looking in the sngrep log asterisk sends 7 invites to the provider which look to be silently dropped.

On the 8th invite the process starts and I get a TRYING, 401, ACK, etc

The first seven invites are exactly the same. The eighth one changes the branch and the cseq

;branch=z9hG4bKPj19bd88c8-32bd-4b55-9dea-53c6f6b33ea4 to a similar but different string.
CSeq: 26846 to CSeq: 26847 increments by one.

If anyone has a hint on where to start on this one, I have tried the tech support but am struggling to get past first level support and being told to turn the computer on and off.


(Elvis) #2

Replying to myself.

I tried a few things to fix the problem and one of them seemed to have worked.

I had the AOR and AOR contact set in the pjsip settings. I had put these in when I was trying to make everything work when I had some problems setting up.

Clearing these values and letting the pbx work them out seems to have fixed the problem. No more extra invites sent that get ignored.

Also I tried changing “user = phone” to YES, this stopped me dialing out and gave the “all circuits are busy now” message. I changed it back to NO in the gui but nothing changed, I had to reboot to get the setting back to NO. This seems like a bug, is there a bug tracker I can report it at?


#3

Sure, at issues.freepbx.org . However, IMO it’s not a bug. Each time you Apply Config, Asterisk immediately re-registers all trunks and I suspect that your provider temporarily blocked you because of too frequent registrations. If you disagree, try to reproduce it, making only the one change and waiting ten minutes before changing it back. If it fails again, instead of immediately trying the biggest club, try just restarting Asterisk. If no luck,
fwconsole restart
and if still no luck, reboot the server. That way, you can document what action is needed to recover.


#4

Assuming Australia, this looks correct. The DID starting 073 (Brisbane) has 7 digits following. The called number (Optus mobile, unless ported) block 04037 has 5 digits following.


(Elvis) #5

Hi Stewart, I saw it in the sip header, USER=PHONE when user = phone was set to no in the config. To clear it I had to reboot. Apply config did not work.

I noticed it this time because it caused me all kinds of grief setting up.Because the change had to be confirmed with a reboot and I didn’t know, I was changing other parameters because I thought they were the ones causing me to not dial out.

I’ll do some checking when I can afford to have downtime, just to make sure I can reproduce this.


(Lorne Gaetz) #6

Very long delay on dial can be caused by flaky STUN server, and it’s the type of thing that might resolve itself if it starts responding again.


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.