Logging into Zulu "Unknown Error" on PC

zulu
Tags: #<Tag:0x00007f7024b577c8>

(jwmb224) #1

Hi All,
Running into problems hooking up Zulu on our Freepbx. Got the model installed, and the server status says “running”.
Our PBX is not visible to the world, and we do not have a domain that we can point to it. So to get a certificate i generated one using OpenSSL. i uploaded it and it’s checked as default.
So from here i assume everything should be ready to go. However, when trying to sign into zulu using “extention@serverip” zulu just says “unknown error”.
Am i on the correct path by installing my own cert and logging in this way? Is there a place i can go to get more detailed information on the error generated by zulu? Any help would be appreciated.

Jared


(Angel Velasquez) #2

Hello @jwmb224

Zulu does not support own certificates, you need a FQDN and a valid certificate in order to make it work.


(jwmb224) #3

Hey @avelasquez,
so just to clarify, zulu cannot be used if the pbx is just operating locally and not visible to the world?


(Lorne Gaetz) #4

I have never had issues using Zulu desktop (windows) with self signed certs, but Zulu mobile requires a proper TLS cert. Standard recommendation is to have a TLS cert.


(jwmb224) #5

Hey @lgaetz
is there a way i can find out what “unknown error” means as a means of troubleshooting this?


(Lorne Gaetz) #6

The client logs are accessible from Preferences -> General and Zulu daemon logs are /var/log/asterisk/zulu*


(jwmb224) #7

hey @lgaetz
i cannot log into zulu to access Preferences. could you be a little more specific for me on the second log you mentioned? i’m trying to access it using the freePBX GUI. Sorry, i’m a bit of a noob and mostly a windows user :slight_smile:


(Angel Velasquez) #8

@jwmb224

This is not what I said :). You can do something like this:

  • Get a FQDN (even if temporary) for that ip.
  • Get a valid cert (letsencrypt is free)

After that, install the certificate that letsencrypt gave you, and then it doesn’t need to be “on the internet” anymore, your local dns service can solve that FQDN to your local ip, and the cert will still be valid.


(jwmb224) #9

hi @avelasquez
i can do that, but i was told on the PBX installation file for zulu that letsencrypt will want to check the cert every couple of weeks, so having the PBX “on the internet” is a requirement.


(jwmb224) #10

@lgaetz @avelasquez any additional thoughts on this guys?


(Lorne Gaetz) #11

Nothing based on what’s provided here. If you have a paid license open a support ticket.


(jwmb224) #12

@lgaetz ok. thank you for the response.


(system) closed #13

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.