Log files are empty

Hi,
Freepbx 4.211.64-7
After updating the ‘Asterisk logfiles’ from 2.11.0.7 to 2.11.0.8
the freepbx gui is not writing the ‘log file settings’ to the appropriate files (logger_general_additional.conf
logger_general_custom.conf,logger_logfiles_additional.conf
logger_logfiles_custom.conf)

logger_general_additional.conf is empty
logger_general_custom.conf is empty
logger_logfiles_custom.conf

logger_logfiles_additional.conf has
fail2ban => notice,security is empty

i also checked the access.log and error.log files but no error there.
Any help please

logger show channels output

localhost*CLI> logger show channels
Channel Type Status Configuration


/var/log/asterisk/fail2ban File Enabled - NOTICE SECURITY

**update
after writing these lines in logger_logfiles_additional.conf
fail2ban => notice
full => debug,error,notice,verbose,warning
console => debug,error,notice,verbose,warning

and in logger_general_additional.conf

dateformat=%F %T
appendhostname=no
queue_log=yes
rotatestrategy=rotate

i did a ‘logger reload’ and asterisk is writing in the full log.
Then i made changes from the freepbx gui 'Asterisk logfile settings’
and got this output
[2014-02-28 15:04:23] ERROR[15916] config_options.c: Attempting to process uninitialized aco_info
[2014-02-28 15:04:23] WARNING[15916] named_acl.c: Could not reload ACL config
[2014-02-28 15:04:23] VERBOSE[15916] config.c: == Parsing ‘/etc/asterisk/manager.conf’: Found
[2014-02-28 15:04:23] VERBOSE[15916] config.c: == Parsing ‘/etc/asterisk/manager_additional.conf’: Found
[2014-02-28 15:04:23] VERBOSE[15916] config.c: == Parsing ‘/etc/asterisk/manager_custom.conf’: Found
[2014-02-28 15:04:23] VERBOSE[15916] config.c: == Parsing ‘/etc/asterisk/http.conf’: Found
[2014-02-28 15:04:23] VERBOSE[15916] config.c: == Parsing ‘/etc/asterisk/http_additional.conf’: Found
[2014-02-28 15:04:23] VERBOSE[15916] config.c: == Parsing ‘/etc/asterisk/http_custom.conf’: Found

Similar issue - since that model update FreePBX ignores the log date format, and for some reason the .conf file is truncated (missing “security =>” line even though that line used to be present before the module update. Of course, from the gui I do still have security=> turned on…

Sounds like something is crashing that the new logger module

There are lots of “included” .conf files. just like the rest of asterisk.

what do you mean by that dicko ?

every line that starts with # in logger.conf refers to another file which is inserted inline at that point. So if you have duplicated lines in different files, or you added another custom line in a custom.conf file then they will all get used, so just read each and every file in order to see what will really be logged.

Dicko - I think you may be reading the original post (and mine) not quite as intended. Nothing had changed with my system other than upgrading freepbx modules. Suddenly loging I had setup in “Settings | Asterisk Logfile Settings” no longer work, lines are missing from logger_logfiles_additional.conf, and I see the same error on the console as noted above.

This doesn’t look like a user issue…I think its a freepbx bug

thats right ocgltd.
I did not changed anything.After ‘asterisk logfiles’ update from 2.16.0.7 to 2.16.0.8 , “Settings | Asterisk Logfile Settings” no longer work,and lines are missing from logger_logfiles_additional.conf.

@assos40 & @ocgltd

You are both posting in the general-help forum, I gave you just that general help, your posts properly belong in the Distro or commercial modules fora as I believe that FreePBX itself does not provide the module you complain about, if that module is broken and until it is fixed then just add

full => notice,warning,error,debug,verbose,dtmf

and possibly, if you need it for IDS

security => notice,security

to

logger_logfiles_custom.conf

issue from bash

rasterisk -x ‘logger reload’

That will make asterisk log again, /var/log/asterisk/myfull and /var/log/asterisk/security will be being populated

Then go and post in the right forum. When you start getting duplicates on your log files delete/comment the patches in your custom log file.

Dick - the logger config is part of basic FreePBX (not even a “module”). I’m hoping that a dev might jump in with a comment?

If you say so, but I disagree you got it by installing the closed source commercial sysadmin module, “Basic FreePBX” is still to my knowledge necessarily open source.

#10
Thats exactly what i did.Thats a workaround.
But the main issue is still there.
"After ‘asterisk logfiles’ update from 2.16.0.7 to 2.16.0.8 , “Settings | Asterisk Logfile Settings” no longer work,and lines are missing from logger_logfiles_additional.conf.“
Hope there will be an update.
#12
I have the closed source commercial sysadmin module installed among other commercial modules,but i am sure that i had a working ‘asterisk logfile report’ and 'asterisk logfile settings” before that.From the freepbx distro installation.

same problem here … from yesterday update, no more log in GUI with errors :

res_clialiases configuration file ‘cli_aliases.conf’ not found

res_config_sqlite3.c: Missing config file ‘res_config_sqlite3.conf’

config_options.c: Attempting to process uninitialized aco_info

I’m still somewhat new to freepbx…do we have to file a bug report somewhere or do devs read the forums?

It appears that the Schmoozecom update for Asterisk Logfiles to 2.11.0.8 breaks the logging settings and produces exactly the behavior ocgltd describes.

Schmoozers, any word on a fix?

Still vthe wrong forum :slight_smile:

Although it is claimed that “the devs never come here” they actually do, and I am sure they are trying to fix this latest snafu, you will only hear from them when they have fixed it, feel free to post a bug though.

It is important for all to know that that FreePBX is not in any way dependent on the Schmooze distribution, conversely the Schmooze distribution , perhaps confusingly called the FreePBX distribution, IS dependent on FreePBX, hence my encouragement to post your problem in the appropriate forum or you dilute the whole concept, I don’t use the FreePBX distribution but have used FreePBX since it was before [email protected] 0.something and never have experienced the problems you guys complain about, asterisk logging is perhaps the most trivial part of settimg up asterisk, just follow what I have said and you can fix your logging problems until Schmooze fixes theirs.

( I have to be careful here, I have been told off before for calling it the Schmooze distribution, it is in fact A FreePBX distribution , much like PIAF or others, it is just published by Schmooze who call it the FreePBX distribution :slight_smile: sorry for the confusion )

Guys

Their is a bug tracker for FreePBX. Please open a bug and it will get a developers attention. Developers do not monitor forums for bugs. We base everything off the bug tracker.