FreePBX | Register | Issues | Wiki | Portal | Support

Lm_sensors.service failed


(Mark Moore) #1

When I ssh in to my FreePBX VM and list running services with systemctl, I see that the lm_sensors.service failed.

My VM is a stock FreePBX image from FreePBXHosting.

Does anyone know what this failure is about? Should this service even be started? If so, why is it failing?


#2

lm_sensors is unlikely to work in a VM as it is pointed at hardware things which you don’t have, I would disable it.


(Mark Moore) #3

Thanks for the super fast response, @dicko! That’s what I was thinking. I can disable it, but it sure seems like it should be disabled by default in the FreePBX VM.

Do you know where to make that suggestion or open a ticket for that?


#4

It makes perfect sense in a physical machine. But conditionally working out whether you are virtual or physical is not so easy (because it’s virtual)


(Mark Moore) #5

There is nothing to work out for the VM’s that Sangoma/FreePBXHosting provision themselves for new customers (like me). 100% of the time, it’s going to be a VM.

They do have options where the image can be run on dedicated HW, but in those cases, 100% of the time it will be real iron.

They obviously have a provisioning script that sets and tweaks a number of items to get a VM running right when a new one is ordered.

I’m hoping someone knows where that script lives and how a customer might be able to suggest an improvement to that configuration script. :wink:


#6

That would be obviously one for Sangoma/FreePBXHosting. They are the only ones in control.


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.