Little adjustments for How to Install FreePBX 15 on Debian 10 with Asterisk 16, PHP 7.3


#21

I went back and reverted then updated the wiki. It is working well for me; I ran through a full install just a bit ago and it took 15 minutes at most. Good news, the odbc-mariadb connector is now part of the standard Buster repo. You don’t need to fetch it from the mariadb site, build it, or anything of the sort. The package has been added to the end of the big apt-get command line.

https://wiki.freepbx.org/display/FDT/How+to+Install+FreePBX+15+on+Debian+10+with+Asterisk+16%2C+PHP+7.3


#22

Thanks for your work and nice info for odbc connector.

I made the installation following your new howto.

I have an error
Unable to install module pm2

I make
apt-get install npm
But then I have a new error when installing pm2 module
npm WARN npm npm does not support Node.js v10.15.2


#23

The instructions specify installing Node 11:

Install Node.js

  • curl -sL https://deb.nodesource.com/setup_11.x | sudo -E bash -
  • apt-get install -y nodejs

#24

The complete message is
npm WARN npm npm does not support Node.js v10.15.2
npm WARN npm You should probably upgrade to a newer version of node as we
npm WARN npm can’t make any promises that npm will work with this version.
npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.
npm WARN npm You can find the latest version at https://nodejs.org/

When installing Nodejs with the instruction specifying node11 the version installed is 10.15.2 (command node --version). Strange


#25

Sorry, I don’t know how you got that, but when I follow the guide it installs Node 11.15.0. Just go back through the guide and make sure you have installed 11.15.0 before moving forward from that step.


#26

Very strange.
I made another installation from scratch and I got the same version v10.15.2
If I look at the debian 10 package nodejs, it is the v10.15.2

https://packages.debian.org/buster/nodejs

During the installation I got

================================================================================

                          DEPRECATION WARNING

Node.js 11.x is no longer actively supported!

You will not receive security or critical stability updates for this version.

You should migrate to a supported version of Node.js as soon as possible.
Use the installation script that corresponds to the version of Node.js you
wish to install. e.g.

Please see https://github.com/nodejs/Release for details about which
version may be appropriate for you.

The NodeSource Node.js distributions repository contains
information both about supported versions of Node.js and supported Linux
distributions. To learn more about usage, see the repository:
https://github.com/nodesource/distributions

================================================================================


#27

Correct, do NOT install the Debian repo package.

This is fine. Let it install and you will get 11.15.0.


#28

Thanks for your fast answers.

I can have the version 11 installed. There is something wrong but I don’t know what and why.

apt-get install -y nodejs seems to get and install the debian package which is the 10.15.2 and not installed the version 11


#29

Hello BillSimon,
Now the freepbx installation is correct.
I think you can add lame in the apt-get install at the beginning
I notice that asterisk does not load the chan_pjsip, chan_sip and chan_iax2 modules. It is necessary to restart it.

When testing freepbx, I notice a problem when using voicemail. It is impossible to register messages.


#30

fwconsole restart step is included for that reason. The drivers don’t load until the config is in place.

I don’t understand what you mean by this. Could you clarify?


#31

Thanks for your answers.

First point : is it fwconsole reload or fwconsole restart?

Second point : I make a call to an extension unavailable, the voicemail is activated but it is impossible to leave a message. In the asterisk log I find
WARNING[10765][C-00000001] app.c: No audio available on PJSIP/1000-00000000??

I call my own voicemail and impossible to personnalize it. I have the same error message in asterisk.

When I look at /var/spol/asterisk/voicemail/default/my_extension_number, there is no file in INBOX, old and urgent.


#32

fwconsole reload (or fwconsole r) applies configs. fwconsole restart restarts Asterisk. If you need to load Asterisk modules and don’t want to do it through CLI, then use fwconsole restart.

This is probably not related to the install; it’s a firewall or NAT configuration problem to troubleshoot separately (either on your own or in a new forum thread).


#33

Thank for your very fast answer.

To load the modules in asterisk I will use fwconsole restart

For the voicemail problem, there is no nat or firewall for this test.


#34

I think it is a stupid problem of DTMF! I 'll check


#35

Thanks again for your help!
Do you think it is possible to change the nodejs version from 11 to 12 or 13?


#36

Curious for other’s experience. Last time I tried v12 things broke.

So far, I’m stayed at v10 as an LTS release.


#37

The latest LTS version is 12.16.2


#38

Yes, but it breaks FreePBX, or at least did for me (admittedly a while back and I didn’t fuss with it).

v11 works, but is EOL. I personally wouldn’t choose it because of that status, unless maybe there was some real benefit(which I’m unaware of, but happy to be enlightened).


#39

I made the installation replacing nodejs V11 by nodejsV12 and everything seems to be OK.

What is the nodejs version in the freepbx distro?


#40

Version 11 was recommended in the Debian 9 install guide for FreePBX 15.

On a FreePBX 15 Distro server, I see:

# node -v
v8.11.3

And a FreePBX 15 / CentOS 8 guide installs version 12. (https://wiki.freepbx.org/display/FDT/[How-to]+Install+FreePBX+15+on+CentOS+8)

So it looks like the software is not closely tied to any version, though it would be nice to know minimum requirements for nodejs version, which I am not able to find right now.