Linux CLI: fwconsole bulkimport command isn't actually importing anything

It’s possible that I don’t totally understand what this is supposed to do, but I’m trying to use a self-generated .csv file to ‘bulk import’ a list of extensions. I’ve tested it with all required headers for one single extension like this: fwconsole bi --type=‘extensions’ extensions.csv. It returns the message “Importing bulk extensions”, but when I check to see if the extension was added on the GUI it isn’t there. Am I missing something? Is this not what this command is supposed to do?

Also, if this command IS to be used for this purpose, is there a way to add users? I believe the only two ‘types’ that can be specified are “Dids” and “Extensions”. Any help is appreciated :slightly_smiling:


fwconsole bi --type=extensions extensions.csv

Can you paste the full output…

Tried it without the single quotes on the type and I’m getting the same thing. The full output on the command line is just “Importing bulk extensions”. But when I check the GUI I’m still not seeing it on the list of extensions.

Please upload some portion of your extension.csv for us to test.

Here are the contents of the .csv file:

extension (5001),
name (Jason),
description (Jason),
tech (Sip),
secret (Secret),
callwaiting_enable (),
findmefollow_enabled (),
findmefollow_grplist (),
voicemail_enable (),
voicemail_vmpwd (),
voicemail_email (),
voicemail_options (),

is that edited or is that literally what you are attempting to import

Well I removed the last name from the name spots. Other than that everything is the same.

Export a CSV to get the proper format then you can reimport it.

on a side note:


works fine

That did it! I guess I took the examples too literally. Thanks much :slightly_smiling:

On to the next question. Can users be added this way?