Line key to blind transfer a call to an external number

I actually had this working using a Line key as a BLF with an external number entered, but it was throwing notices in my error log constantly and causes my phones to disconnect/reconnect, so I need another solution.

I get calls which are actually trying to reach another number, but they get me by mistake. I had been able to put them on hold and hit my BLF key to blind transfer them to the correct number. That was causing a problem with my phones, as BLF’s are intended to work with from-internal extensions and not external numbers.

I have tried setting up a speeddial, but that did not work. I have tried setting up a Ring Group with the external number, but that did not work. It seems that, to get the desired behavior, I have to find a way to set this up on a BLF, but I have the issue that I constantly receive the following notice in my log and the phones constantly disconnect/reconnect:

[2019-09-18 09:08:59] NOTICE[28117] res_pjsip_exten_state.c: Endpoint ‘zzz’ state subscription failed: Extension ‘XXXXXXXXXX’ does not exist in context ‘from-internal’ or has no associated hint

Thank you for your insight.

Sangoma S505 running firmware version, FreePBX, PBX Firmware 12.7.6-1904-1.sng7, Current Asterisk version 13.22.0

BLF with an external number does not make sense; you cannot monitor an external number. What if you set up the button as a plain speed dial, not a BLF?

(Edit - I did see that you said you tried setting up a speed dial, but assumed you meant you set up an Asterisk speed dial and then configured the BLF for that. If you already tried the button-based speed dial, disregard… though that should work fine)

This was discussed in the IRC channel. These are the options:

  1. You set the phone up to use Blind Transfer as its default transfer option. Hit the transfer button and enter the number you want to transfer to and hit transfer to complete.

  2. You use an Attended Transfer option of the phone. Repeat process of step 1.

  3. If this is always to the same number you setup a speed dial on the phone using the InCall Blind Transfer option of ###

  4. If this is to different numbers you need to write a macro for the phone so that when the softkey is pressed it enters the ## for you, prompts you for where you want to send the number and then have the macro append the close # for you.

Also, if you are having issues with your phone disconnecting/registering over and over again because you had a bad BLF subscription then something else is going on and causing this. All that’s going to happen is the phone is going to get back a 404 User Not Found reply to the SUBSCRIBE attempt to this non-existing number in the system. That in no way should cause the phone to drop registration and re-register…


I apologize, I may have misspoke. I was using the Line Key in BLF mode not for monitoring purposes, but for the default behavior or automatically blind transferring the held active call to the number associated with the BLF. It worked absolutely perfectly aside from the constant notices being thrown into the log. Despite it not making any sense for this to be causing the phones to reboot constantly, once the Line Key was changed away from BLF the notices stopped flooding the log and the phones stopped perpetually rebooting. Now I am trying to find another way of recreating the “Place call on hold, Hit line key to immediately blind transfer the call to an external number”.

To answer your question directly: when using a speeddial key, as I have had it set up, it places the current call on hold and then calls the speeddial-programmed number without performing the transfer automatically. I think Tom below has suggested the fix, I just need to try it.

I forgot to mention, and so I will edit the post to add the information, which phones and distro versions I am using.

Sangoma S505 running firmware version, FreePBX, PBX Firmware 12.7.6-1904-1.sng7, Current Asterisk verison 13.22.0

Maybe that is my issue. I had been using the BLF key set with ## before the number. The speeddial button was not functioning as desired with that. I suppose I had one too few # symbols. I’ll give that a shot.

The goal is to just put the call on hold and hit blind transfer the active call by hitting the line key.

When using the ## or *2 feature codes to transfer calls, you need to be in the call because these are InCall features. By using them, they put the caller on hold and then do the rest.

In fact the Transfer keys on phones do the exact same thing. You hit the Transfer button and they put your current call on hold and then open a new line to do the transfer. At no point in using any of these two options should the caller be put on hold first because then you’re just opening a new line to make a new call.

Thank you for the clarity. I miss-remembered how we were using that key, then. Just hitting the button without placing the call on hold would be preferred and must have been how it was working originally. I apologize.

I will see if I can find some details on how to make a macro that will accomplish the same thing. It’s just a single number that is being transferred to.

So, I’ve tested the following speeddial settings, and none of them have worked. Am I missing something basic?

Speeddial setups:

When I hit the linekey, the phone says “transferring” at the top, but just drops the call.

So if it says Transferring then the PBX accepted the ## and is transferring the call. You’re going to have to look at actual debugs of this to see what is happening with the call. It could be attempting to transfer and failing for some reason.

Shouldn’t the speed dial just be XXXXXXXXXX ? no # signs?

I must have just assumed I needed the # symbols. I’ve re-tested the speeddial option with just the number I need the call transferred to. It behaves exactly as I desire. This thread can be closed as resolved.

To summarize, I have a Line-key set to Speeddial a telephone number. I receive a call, and with that call still active I hit my speeddial Line-key. The call is immediately blind transferred to the number associated with the speeddial. No further action is needed on my end.

I don’t know if something changed or if I somehow missed testing this before. I was fairly sure I had tested this and that the result was the inbound call was placed on hold while my phone placed an outbound call to the programmed speeddial without transferring the call.

Not sure if I changed or if the phone behavior changed, but a normal speeddial button now works as desired for me. #ifeeldumb

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.