Limit the Ring Time

When one extension calls another one, it seems to ring for ever ( more than 3 minutes)

How can I limit the extension to ring only 1 minutes ? If the extension doesn’t answer within 1 minute hang up the phone.

Even i configure rtptimeout but didn’t get success.

How can i do anyone can help me out ?

In a typical system, an unanswered call would go to voicemail. If your system (or some extensions) won’t be using voicemail, in the Advanced settings for the extension(s), set No Answer to e.g. Terminate Call, Hangup and set Busy to e.g. Terminate Call, Busy.

If you don’t set a ring time for each extension, it will use the value in Advanced Settings -> Ringtime Default, which you would change to 60 if you want the extension to ring for a full minute.

Thanks Stewart1…!

I have configured ring time for all extension using option available in advanced setting of Free PBX and call connected to receiver and disconnected after 30 sec(as i configured) from receiver end but call is still continue at sender end and it’s takes more than 5 minutes to disconnect current call.

So,Could you please suggest, which configuration i am missing in free PBX so both receiver and sender call disconnected at same time.

Sorry, I don’t understand what is going wrong.

What No Answer destination did you set for the called extension?

Are you saying that if the caller hangs up, the call continues on his device for 5 minutes, so he can’t make or receive another call? If so, what make/model phone or other device is he using? If he cancels the attempt before 30 seconds, does that work normally?

Or, are you saying that if the caller accidentally leaves the phone without hanging up, the phone doesn’t disconnect? This may depend on the device. Why is it a problem, e.g. is it making a noise that disturbs others?

Just a guess, try routing No Answer to Terminate Call -> Play SIT Tone. If that solves the issue but you don’t want to play that sound, create a suitable Announcement (which routes to Terminate Call -> Hangup after playing).

thanks for your response.

my requirement is when one person dial any number to call other person on his extension. if other person is not picking my call before 20 sec then call automatically disconnected at both end caller end as well as receiver end.

how can we achieve this?.

How is the No Answer field for the destination extension set now?

Specifically, what goes wrong at the caller end (he continues to hear ringing, the phone doesn’t disconnect when he hangs up, etc.)?

What kind of device is he using (IP phone make/model, softphone, SIP app on smartphone)?

Did you try my suggestion about Play SIT Tone? If so and it didn’t help, did it change any of the symptoms?

You are describing FreePBX normal default fuctionality.

I don’t believe that’s the case, based on the tool tip for Extension -> Ring Time, which says “If no voicemail is configured this will be ignored.”, so I’m pretty sure that you have to configure a suitable No Answer destination.

I apologize. I reread the thread and yes I misunderstood your question.

There’s a default ring time which can be configured in advanced settings or on each extension individually.
Note: If you set this up in advanced settings it will not override existing extensions ring time, only extensions created after setting this up will pull the default ring time… But as mentioned you can always configure each extension’s ring time in the extension’s advanced settings tab.

If you want to calls to terminate after the ringtimr you’ve set, you can set destination if no answer to terminate the call.

If i found no answer then call should be terminated i configured that.

Configured ring time from advanced settings at 20 sec but call disconnected from both end after 26 sec from sender end and receiver end even i reconfigured ring time 15 sec then also call disconnecting after 26 sec i don’t understand how can i configured so that call disconnect at our given tim(like 20 sec, 15 sec) from both end.

i am using x-lite and freePBX.

Thanks PitzKey.

i Configured ring time 20 sec from advanced settings and also configured if found no answer then terminate the call but call is terminating after 26 sec even i reconfigured ring time 15 sec then again call terminating after 26 sec .

could you please let me know why this thing happen if ring time is 20 sec why then ringing about 26 sec ?

I’m just asking this because there were people who missed it… - did you apply config after making changes?

To answer why it’s still not working as configured, you’ll have to provide call logs.

Thanks for response Stewart1.

I configured ring time from advanced settings and also i configured in extension setting if found no answer terminate call it’s working but when we are going to call on cell phone then how can we do if found

"no answer == terminate call"
then terminate the call(because when we are going to call on cell phone in that case how can configure any cell phone number for no answer field == terminate call)

please let me know.

yes i did.

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.