Lets encrypt not auto updating for websocket server


(Mike Olsen) #21

no change in the files. if i try to access the hostname and port directly in chrome I still get the expired cert error:

however the admin pages are fine (expires in October)


(Andrew Nagy) #22

Ok so now run

fwconsole certificate list

Find the certificate ID you want to use

then run

fwconsole certificate default <id>


(Mike Olsen) #23

ok done. only one showed up on the list, so i ran fwconsole certificate default 0 and it says successful.

did an ls -lt, dates updated! going to restart the server to see if the ssl error is gone


(Andrew Nagy) #24

Ok so now update to certman v13.0.32

Then hopefully you wont have to come back in three months :slight_smile:


(Mike Olsen) #25

that did it! any log files you need in case this is a bug?


(Andrew Nagy) #26

See above. It was a bug but is now fixed. I fixed it while going through debug with you, which is why I kept hammering you for information.


(Mike Olsen) #27

hehe. you’re freaking awesome. thanks!!


(Andrew Nagy) #28

No problem. Thanks for being patient!


(Claudio Pelosi) #29

how do i configure chan sip to work wss?