Let's Encrypt certificate imported locally - Your connection to this site is not secure

I installed a let’s encrypt certificate on FreePBX Distro (SNG7) and imported it locally to be able to access FreePBX GUI via https.

I am however getting the “Your connection to this site is not secure” red triangle in my browser saying that I have an invalid certificate.
What am I missing?

The certificate is assigned to the FQDN, not to your IP.

Imagine setting up two FQDN’s pointing to the same server.

a.example.com
b.example.com

So when you generate a certificate for a.example.com and you will try to go to https://b.example.com you’ll get the same error.

So if you want the green lock, you’ll have to go to the FQDN. (you can allow 443 from trusted locations only)

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.