Lenny not working?

Hi everyone,

I am currently trying to set up Lenny for spam callers. I am running into one issue with Lenny that I can’t see to solve. When I call his extension, or transfer out to it, it is giving me the busy tone. The message is “no response.” I’ve checked everything and can’t pin point whats wrong.

Does anyone know what can be wrong, or what I can try to finish setting it up? The files are in their correct folder, I put them in both for now. The extensions_custom.com is set up properly. Custom extensions is set up properly. I cant identify what may be wrong. The extension is a virtual extension and is not programmed on any phone.

These are the instructions I followed:

1 Like

Actually, I realized the mistake I made. I edited extensions_custom.com instead of extensions_custom.conf.

Now I have a different issue. I am call extension 798 internally and hear Lenny. But when I call an inbound route and transfer to extension 798, the busy dial tone appears and hangs up. Any idea?

All 3 optional destinations are set to the custom destination Lenny.

I deleted the virtual extension and changed it to a chan_sip extension and it’s working now. Everything is perfect. Just in case anyone has any issues.

It’s a fun project, but for anyone who wants to give this a try, be aware that ownership and licensing of the sound files is unknown. To my knowledge, nobody has been granted permission to use them despite repeated requests going on for years.

edit 2 years later - the licensing is no longer ambiguous, permission has not been, and has never been granted for public usage:

Hi Lorne!

The one who must not be named here :wink: said multiple times on his website that a guy named Brian West (which is apparently the author of FreeSwitch…) gave permission to use the Lenny recordings for those that want to host their own “Lenny”.

Does anyone actually have it in writing somewhere, I don’t know…,

Have a nice day!

Nick

Brian West never gave permission. We have talked to Brian West (Lorne was there once or twice) in person. Brian is not the author of Freeswitch he is a cofounder and developer. Brian has made it clear that he never gave permission to Ward Mundy to use the sound files. Ward has only talked to Brian over email. Never in person. Remember that WM is giving a legal opinion about an email interpretation. He is a retired lawyer. Not a currently practicing lawyer. As he says you shouldn’t take legal advice form the peasants of FreePBX so nor should you take legal advice from a retired lawyer.


The “legal” issue above was never resolved but the files are still hosted. A legal “grey” area that is supported by Ward Mundy and PIAF.

2 Likes

I see you have the Lenny files in both /var/lib/asterisk/sounds/Lenny AND in /var/lib/asterisk/sounds/en/Lenny Do the files need to be in both places?

I haven’t been able to get Lenny to work in FreePBX 13. I tried changing from a virtual extension to a chan_sip extension like you did but found no joy. With the virtual extension I just got busy signal. When I changed it to chan_sip I get a fast busy signal, but I only have the files in the /var/lib/asterisk/sounds/en/Lenny

I had the exact same problem. Changing it to a chan_sip extension worked great for me as well!