LDAP Users sync but no groups UCP can't log in - Synology

Hi Everyone!

I have a clean install on a new VirtualboxVM for staging right now. Only thing i have done was update the modules and some of the back end items. yum update style.

Asterisk 13.19.1

This was installed from one of the sangoma iso images so I think the OS is SangomaOS. - “SNG7-PBX-64bit-1805-1”

I have a directory server running on a Synology Diskstation that runs LDAP version 3 RFC2251.
I have been able to get other web applications to sync up correctly and have been able to log into said applications with the credentials from Synology Directory Server but no joy with FreePBX under the user management section. I should note that I did not pick Legacy.

I have taken a look at a few forum posts and the “Internal Notes on PBX and OpenLDAP” and they all seem to contradict one another a little bit. The specif way it says to bind is “Bind DN: Must be set to admin LDAP credentials - example: cn=admin,dc=companydnsname,dc=com” however my server shows that the Bind DN should be “uid=root,cn=users,dc=companydnsname,dc=com” If i try to use cn=admin (and have an admin with that specific credentials to use) it does not connect but when I do the way Synology says to bind it will work.

Essentially it “works” but does not sync groups (not a huge deal, I can manage that locally) but even after creating a group and giving access to UCP we can not log in. (giving individual access instead of group doesn’t work either) I keep getting an “Invalid Login Credentials” message. I have tried [email protected] domain\user domain.com\user and really any other style i could try.

When i click the reset password link, I do get an email with the username as (jsmith) in it so it looks like the username is correct from the UCP stand point.

I should note that I am not experienced when it comes to LDAP. I am currently using it to sync users between different Synology servers and they have a gui that works with each other as expected and a hand holding guide so i have not had to dive into the actual guts of LDAP too much other than the one or two web apps that I got lucky on and it worked right out of the box.

Any suggestions and thoughts would be appreciated. Maybe someone knows a little more about the specific version of LDAP the Synology is running and if it even supports the style that is running on FreePBX.

If it would help i would be happy to post my configuration [email protected] style.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.