FreePBX | Register | Issues | Wiki | Portal | Support

Latest (sng7-testing) kmod updates failing install pre-check


(Matt Hettermann) #1

Latest set of kmod updates from yum fail install check with these issues:

Resolving Dependencies
–> Running transaction check
—> Package kmod-cciss.x86_64 0:3.6.26-6.sng7 will be updated
—> Package kmod-cciss.x86_64 0:3.6.26-7.sng7 will be an update
–> Processing Dependency: kernel(sme_active) = 0x7ae5ad74 for package: kmod-cciss-3.6.26-7.sng7.x86_64
–> Processing Dependency: kernel(__check_object_size) = 0x88db9f48 for package: kmod-cciss-3.6.26-7.sng7.x86_64
—> Package kmod-forcedeth.x86_64 0:0.64-5.sng7 will be updated
—> Package kmod-forcedeth.x86_64 0:0.64-6.sng7 will be an update
–> Processing Dependency: kernel(sme_active) = 0x7ae5ad74 for package: kmod-forcedeth-0.64-6.sng7.x86_64
—> Package kmod-via-rhine.x86_64 0:1.5.1-5.sng7 will be updated
—> Package kmod-via-rhine.x86_64 0:1.5.1-6.sng7 will be an update
—> Package kmod-via-velocity.x86_64 0:1.15-3.sng7 will be updated
—> Package kmod-via-velocity.x86_64 0:1.15-4.sng7 will be an update
—> Package sangoma-release.x86_64 0:7-5.1805.02.el7.sangoma will be updated
—> Package sangoma-release.x86_64 0:7-6.1810.3.el7.sangoma will be an update
–> Finished Dependency Resolution
Error: Package: kmod-cciss-3.6.26-7.sng7.x86_64 (sng7-testing)
Requires: kernel(sme_active) = 0x7ae5ad74
Error: Package: kmod-cciss-3.6.26-7.sng7.x86_64 (sng7-testing)
Requires: kernel(__check_object_size) = 0x88db9f48
Error: Package: kmod-forcedeth-0.64-6.sng7.x86_64 (sng7-testing)
Requires: kernel(sme_active) = 0x7ae5ad74
You could try using --skip-broken to work around the problem
** Found 8 pre-existing rpmdb problem(s), ‘yum check’ output follows:
cloog-ppl-0.15.7-1.2.el6.x86_64 has missing requires of libgmp.so.3()(64bit)
hal-info-20090716-3.1.el6.noarch has missing requires of hal >= (‘0’, ‘0.5.10’, None)
libdc1394-2.1.2-3.4.el6.i686 has missing requires of libusb-1.0.so.0
libdc1394-2.2.2-3.el7.x86_64 is a duplicate with libdc1394-2.1.2-3.4.el6.i686
librtmp-2.3-1.el6.rf.x86_64 has missing requires of libgnutls.so.26()(64bit)
librtmp-2.3-1.el6.rf.x86_64 has missing requires of libgnutls.so.26(GNUTLS_1_4)(64bit)
ppl-0.10.2-11.el6.x86_64 has missing requires of libgmp.so.3()(64bit)
2:vim-enhanced-7.4.258-1.shmz65.1.4.x86_64 has missing requires of perl(:MODULE_COMPAT_5.10.1)

This is a up-to-date distro system, but was sequentially updated over the years via old school upgrade scripts (and then the system updates GUI/plain “yum update” more recently)


(Andrew Nagy) #2

You are in the testing repo. yum remove sangoma-devel