Kickstart issues

I tried to install on a multiple disk server yesterday that was running [notag]AsteriskNow 1.7[/notag] with no luck. Then I also tried installing as an VirtualBox instance which worked, but had some install warning/errors though usable. After more poking around in the kickstart I have found the following problems:
[list=1]
[*]in the %pre section groupadd -r asterisk fails as there is no groupadd available at that stage. From ks-script-3yXOpf.log:
/tmp/ks-script-3yXOpf: line 3: groupadd: command not found

[*]zerombr yes is deprecated, so the yes needs to be dropped. From anaconda.log:
15:18:06 WARNING : /usr/lib/python2.4/site-packages/pykickstart/parser.py:977: DeprecationWarning: Ignoring deprecated option on line 46: The zerombr command no longer takes any options. In future releases, this will result in a fatal error from kickstart. Please modify your kickstart file to remove any options.

[*]the part-include that is created from the %pre section of the kickstart is not working. I have not gotten to why on this one worked out, but hope to get to it today.

The group add thing is not a big deal as we have the user added. I will move that to firstboot just to be safe. The item 2 is handled by the RPM I believe but I will need to dig into that more.

Item 3 I am not sure what you are referring to. What include is not working as we have had no issues with this yet and have had over 4000 downloads of the ISO already.

You are right, 1 and 2 are really minor, but I brought them up in case they had been overlooked in development before production. Not sure if adding the asterisk group is needed in firstboot as the group seems to be added during the install.

For #3, in the pre section of the kickstart a check is made as to whether there are multiple disks that need to be added into a RAID set. If RAID is needed, then the lines needed for the RAID setup part of the kickstart are written to /tmp/part-include and then echoed out to be part of the kickstart. When I run the install, I get a kickstart error from the lines of /tmp/part-include. Kickstart seems to not like the sda of ondisk for some reason. I am sorry that I do not have more info on this for you right now, but I wanted to make you aware before folks start to install on multiple disk production hardware like I am doing. My server is a Supermicro, but I do not have the motherboard model in front of me at the moment.

OK well let us know what motherboard. We have verified the raid setup works and I have tried this on 4-5 different motherboards. We also use the same setup for our commercial product and have it on thousands of systems with raid always being setup fine.

The motherboard is setup with a fake RAID mirroring the first 2 disks. When the kickstart is trying to setup raid, it is trying to use the underlying disks instead of the the fake RAID disk and that causes the installer to fail.

Once my Centos install on the server is done, I will destroy the fake RAID and see if everything works as expected.

Going forward I am not sure if it is better to make a note about this condition, add code to work with fake RAID or add code to check for fake RAID and punt.

Hi there,

I have the same problem. My server configuration has 2 identical hard-drives with raid controller that is setup with the fake RAID mirroring. When starting the install centos detects the raid controller, loads the module but the kickstart is trying to install on sda and sdb instead of md (the label for the fake raid mirror)

On a simple centos 5.x install i can choose the raid controller instead of sda/sdb drive and it works fine, tested by myself.

Please tell me that is there a way to avoid the predefined path during the installation

Thx

My advice would be to turn off the FakeRaid in the BOIS and use Linux software raid.
(Reset the disks to non-raid too)

You’ll likely find that it performs better and management/monitoring is much easier with mdadm. In fact the System Config module will let you set up monitoring so that you’ll get an email notification of a drive fails.

thanks for the advice.

After some white nights i figured it out. I had 2 problems:
1- freepbx distro forces to intall the software raid if it detects a fake raid. i could install AsteriskNOW distro but freePBX one … not a chance

2- my server doesn’t provide any CD or DVD drive. i burned on my usb stick the iso with the distro and tried to install from it. CentOS distro install’s nicely from the usb drive, but freePBX doesn’t because of the custom kickstart file. I think centos is a nice partition manager and should be left as it is.

How i solved it ? This is not quite a nice way but worked for me:

  • took out the server hard drives and installed freepbx distro on a normal PC till the first reboot, without raid controller.
  • moved back my hard drives to the server

centos detected the new system and now it works just fine.

If its not too techy to ask (though you seem quite adept) – What driver did centos pull to manage your raid controller? I’ve been struggling with an Intel on-board RAID myself and I may take a crack at helping these situations.

In the end, in my case, it looks like I will leverage the software raid (1) as the controller doesn’t seem to remember boot blocks.

Hello,

Last year i configured with software raid the 2 hdd’s as the distro does automatically.

Yesterday my sda main drive failed with bad sectors. I stopped the machine and started only with sdb drive. I found out that on the second drive, sync had only the OS system installed with settings. It didn’t sync the recordings and the CDR. I had no erors or warnings as a failure notification. Luckily i could recover all the files (long live ext3 file system)

Is this normal ? I think at the beginning i started the system with only one hard drive to test the mirror and maybe that’s why those had 2 versions of PBX. It should of noticed me that’s not syncing anymore …