Kernel Update: Error: Package: python36u-vega-1.2.3-1.sng7.x86_64 (@sng-pkgs/7.4)


(Anton ) #1

I am facing problems when yum update my sangoma centos 7 system.

Can anyone help me with this to be updated with everything.

Thank you so much,

Bellow you can see the log.

Error: Package: python36u-vega-1.2.3-1.sng7.x86_64 (@sng-pkgs/7.4)
Requires: python36u-setuptools
Removing: python36-setuptools-39.2.0-4.el7.ius.noarch (@ius)
python36u-setuptools = 39.2.0-4.el7.ius
Obsoleted By: python3-setuptools-39.2.0-10.el7.noarch (sng-base)
Not found
Available: python36u-setuptools-33.1.1-1.ius.centos7.noarch (sng-pkgs)
python36u-setuptools = 33.1.1-1.ius.centos7
Available: python36u-setuptools-36.6.0-1.ius.centos7.noarch (sng-pkgs)
python36u-setuptools = 36.6.0-1.ius.centos7
Available: python36u-setuptools-39.0.1-1.ius.centos7.noarch (sng-pkgs)
python36u-setuptools = 39.0.1-1.ius.centos7
Error: Package: python36u-vega-1.2.3-1.sng7.x86_64 (@sng-pkgs/7.4)
Requires: python36u
Removing: python36-3.6.8-2.el7.ius.x86_64 (@ius)
python36u = 3.6.8-2.el7.ius
Obsoleted By: python3-3.6.8-13.el7.x86_64 (sng-base)
Not found
Available: python36u-3.6.4-1.ius.centos7.x86_64 (sng-pkgs)
python36u = 3.6.4-1.ius.centos7
Available: python36u-3.6.5-1.ius.centos7.x86_64 (sng-pkgs)
python36u = 3.6.5-1.ius.centos7
Available: python36u-3.6.7-1.ius.centos7.x86_64 (sng-pkgs)
python36u = 3.6.7-1.ius.centos7
Error: Package: python36u-vega-1.2.3-1.sng7.x86_64 (@sng-pkgs/7.4)
Requires: python36u-libs
Removing: python36-libs-3.6.8-2.el7.ius.x86_64 (@ius)
python36u-libs = 3.6.8-2.el7.ius
Obsoleted By: python3-libs-3.6.8-13.el7.x86_64 (sng-base)
Not found
Available: python36u-libs-3.6.7-1.ius.centos7.x86_64 (sng-pkgs)
python36u-libs = 3.6.7-1.ius.centos7


(Jared Busch) #2

You don’t have CentOS 7. You have SNG7. They are not the same thing.

Your problem is you added extra repositories that are causing package conflicts.


(Anton ) #3

Ah, you are right, thanks for that.

Can you help me to remove this?


(Jared Busch) #4

Well why did you add it in the first place? There should be a reason.

Removing is easy, but that will likely break whatever reason you had for installing it.

List out the repos installed.

yum repolist 

The try and update with ius temporarily disabled. Might be named ius-release, hence the repo list first.

yum update --disablerepo=ius 

(Anton ) #5

The reason was I think because of installing osticket on this machine. Afterwards I did install this in a docker container.

I tried the steps but no luck, however the problen did change:

yum repolist

repo id repo name status
docker-ce-stable/x86_64 Docker CE Stable - x86_64 122
ius/x86_64 IUS for Enterprise Linux 7 - x86_64 477
mondorescue rhel 7 x86_64 - mondorescue Vanilla Packages 184
nunodias-Powerstat/x86_64 Copr repo for Powerstat owned by nunodias 4
sng-base/7/x86_64 Sangoma-7 - Base 10,070
sng-epel/7/x86_64 Sangoma-7 - Sangoma Epel mirror 15,649
sng-extras/7/x86_64 Sangoma-7 - Extras 413
sng-pkgs/7/x86_64 Sangoma-7 - Sangoma Open Source Packages 1,940
sng-updates/7/x86_64 Sangoma-7 - Updates 1,127
tuxad/x86_64 Extra Packages for Enterprise Linux 5 - x86_64 101+8
webtatic/x86_64 Webtatic Repository EL7 - x86_64 789
repolist: 30,876

yum update --disablerepo=ius

Loading mirror speeds from cached hostfile

  • webtatic: uk.repo.webtatic.com
    Resolving Dependencies
    –> Running transaction check
    —> Package kernel.x86_64 0:3.10.0-1127.19.1.el7 will be installed
    —> Package python3.x86_64 0:3.6.8-13.el7 will be obsoleting
    —> Package python3-libs.x86_64 0:3.6.8-13.el7 will be obsoleting
    —> Package python3-pip.noarch 0:9.0.3-7.el7_7 will be obsoleting
    —> Package python3-setuptools.noarch 0:39.2.0-10.el7 will be obsoleting
    —> Package python36.x86_64 0:3.6.8-2.el7.ius will be obsoleted
    –> Processing Dependency: python36u for package: python36u-vega-1.2.3-1.sng7.x86_64
    —> Package python36-libs.x86_64 0:3.6.8-2.el7.ius will be obsoleted
    –> Processing Dependency: python36u-libs for package: python36u-vega-1.2.3-1.sng7.x86_64
    —> Package python36-pip.noarch 0:9.0.1-2.el7.ius will be obsoleted
    —> Package python36-setuptools.noarch 0:39.2.0-4.el7.ius will be obsoleted
    –> Processing Dependency: python36u-setuptools for package: python36u-vega-1.2.3-1.sng7.x86_64
    –> Running transaction check
    —> Package python36u.x86_64 0:3.6.7-1.ius.centos7 will be installed
    —> Package python36u-libs.x86_64 0:3.6.7-1.ius.centos7 will be installed
    —> Package python36u-setuptools.noarch 0:39.0.1-1.ius.centos7 will be installed
    –> Finished Dependency Resolution
    –> Running transaction check
    —> Package kernel.x86_64 0:3.10.0-957.21.3.el7 will be erased
    –> Processing Dependency: kernel(usb_alloc_coherent) = 0x46855936 for package: kmod-dahdi-linux-2.11.1-53.sng7.x86_64
    –> Processing Dependency: kernel(usb_free_coherent) = 0xefe7d2e2 for package: kmod-dahdi-linux-2.11.1-53.sng7.x86_64
    –> Processing Dependency: kernel(usb_init_urb) = 0x1cf8caaa for package: kmod-dahdi-linux-2.11.1-53.sng7.x86_64
    –> Processing Dependency: kernel(usb_reset_device) = 0x143ace2f for package: kmod-dahdi-linux-2.11.1-53.sng7.x86_64
    –> Processing Dependency: kernel(usb_submit_urb) = 0xa74beb34 for package: kmod-dahdi-linux-2.11.1-53.sng7.x86_64
    –> Running transaction check
    —> Package kmod-dahdi-linux.x86_64 0:2.11.1-53.sng7 will be erased
    –> Processing Dependency: kmod-dahdi-linux for package: freepbx-14.1-1.sng7.x86_64
    –> Processing Dependency: kmod-dahdi-linux for package: dahdi-linux-2.11.1-50.sng7.x86_64
    –> Processing Dependency: kmod-dahdi-linux for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(__dahdi_ec_chunk) = 0x4ec395b3 for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(__dahdi_mulaw) = 0x006a2198 for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(_dahdi_ec_span) = 0xcc46278d for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(_dahdi_receive) = 0xb29e73c7 for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(_dahdi_transmit) = 0x30205df3 for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(dahdi_alarm_channel) = 0xfecd461c for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(dahdi_alarm_notify) = 0xef647b7a for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(dahdi_create_device) = 0x3ae79bcd for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(dahdi_free_device) = 0x49a1accf for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(dahdi_hdlc_finish) = 0x9269317c for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(dahdi_hdlc_getbuf) = 0x9b235c63 for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(dahdi_hdlc_putbuf) = 0x9f6f3391 for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(dahdi_hooksig) = 0x0d84d211 for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(dahdi_qevent_lock) = 0xd23df842 for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(dahdi_rbsbits) = 0x0c0097ad for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(dahdi_register_device) = 0x9a9693bf for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Processing Dependency: ksym(dahdi_unregister_device) = 0xb14f1179 for package: kmod-wanpipe-7.0.32-1.sng7.x86_64
    –> Running transaction check
    —> Package dahdi-linux.x86_64 0:2.11.1-50.sng7 will be erased
    –> Processing Dependency: dahdi-linux for package: dahdi-tools-2.11.1-2.sng7.x86_64
    –> Processing Dependency: dahdi-linux for package: libopenr2-1.3.4-1.6.sng.x86_64
    —> Package freepbx.x86_64 0:14.1-1.sng7 will be erased
    –> Processing Dependency: freepbx for package: sangoma-pbx-2107-3.sng7.noarch
    —> Package kmod-wanpipe.x86_64 0:7.0.32-1.sng7 will be erased
    –> Running transaction check
    —> Package dahdi-tools.x86_64 0:2.11.1-2.sng7 will be erased
    —> Package libopenr2.x86_64 0:1.3.4-1.6.sng will be erased
    —> Package sangoma-pbx.noarch 0:2107-3.sng7 will be erased
    –> Finished Dependency Resolution
    Error: Trying to remove “sangoma-pbx”, which is protected