Kernel Panic

Current PBX Version:

Current System Version: 12.7.8-2008-1.sng7

Was running latest version of the distro – decided to run a yum update from the CLI – had a ton of updates come across – so downloaded and installed them

Rebooted the server and suddenly had a kernel panic

Went to talk a look at the bootup and noticed that if i boot into 3.10.0-1127 it panics and crashes

If I switch back to 3.10.0-957 boots up fine

Server is a VM hosted on Vultr – does 1127 have issues with VM hosts?


I don’t know.
I will try to install on my server.
I’ve got an ESXi server and an VirtualBox server. I could try to compare if you want.

Be patient, the time to test :slight_smile:

so i went back in and noticed that when i ran yum there were some issues – i ran the commands to clean everything up and things looked ok

then i ran a yum reinstall kernel – it took a little bit – but that finished ok as well

then i hit reboot

and when the vm came back up i am stuck at the grub menu and can not boot into the system

ls shows hd0, hd0, msdos2 and hd0 msdos1

when i type boot into grub it says that i need to load the kernel first

how can i get grub to boot the system

Hmm Wow.
I could try to install on VirtualBox.
This server has a RAID 10 (software).
I know I’ve had some problems to import vmdk file from ESXi server to Virtualbox because the partition was messed up on my system.
So, perhaps, I could get the same issue like you?

I will download the iso file this night and try to install it tomorrow.

Since i needed this system to be operational – i decided to reinstall from a backup from 2 days ago and now i am back to where i was before all this mess –

So to start again i am now back to currently running Sangoma Linux release 7.5.1805 (Core)

This time however when i do yum clean all and yum update i get no updates available

Should i just leave it alone for now?


Yep. Don’t touch it for now please.
I will test it asap and I will come back to you.
BTW, I will inform our QA team to test it as well.

I’m having the same exact problem. I ran a yum update, it downloaded a bunch of updates and then kind of got stuck. As I am not an expert in linux, I ran the yum update again. I hope this didn’t confuse the system. Once the yum was finished, I decided to reboot the server from the GUI. It never came back on. I had to drive down to where the server was and manually restart it. I had the same results, if I let it run it gives me a kernel panic, (shown below). If I choose linux it boots up just fine.

Hi Steve.
Thanks for your feedback.

I’m installing this iso file on Virtualbox / Ubuntu server with RAID 10 software on a HP DL120 G
Wait and see

On my first install, I successfully installed FreePBX 15 from iso file. But if you’ve got something to update here through yum update, Maybe the issue is there.
I’ve had some problems to update something in FreePBX 14 as well pointing on a wrong URL for update.

I did it like this

  • Install FreePBX 15 iso
  • login on root
  • yum clean all
  • yum update -y


A script on our mirror server has been fixed yesterday evening.
This one has fixed my issue with update on FreePBX 14 and I think it fixed your issue as well.

I don’t know how to get back on the previous kernel and remove it. (I’m not really a specialist on this point).
I will try to include someone in this thread to help you.

Let me know guys.


I was able to remove the faulty kernel. I was hoping that when I ran another yum update, my system would see I was using an older kernel and update it to the newer one. That didn’t happen, it just says no packages marked for update. So how do I update to the newer kernel? (I’m kind of a noob)

The ISO file is recent, so I can imagine the kernel is up to date. (at least for our repos).
I’ve got the same result like you anyway. But don’t worry, if there was some update in the future, yum should get them.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.