IVR won't accept DTMF tones

I have an issue with an IVR menu that I’m trying to setup where it won’t accept a DTMF tone entry during the first playback of the recording. Once the recording completes the first time, you can enter options all day long, but during the FIRST recording it won’t accept them.

You can watch the logs during the recording playback, and it won’t recognize the dialed tones anytime during that first playback, and then suddenly when it’s done, you can punch a number and see it pop right up in the logs and it works properly.

I’ve tried every combination of dtmfmode (auto,inband,rfc2833) on the trunk config to no avail. All dtmf works with every other aspect of the system as well (VM, conferencing, etc).

Thanks in advance for any guidance.

It’s like the IVR is acting as early media.

Create a short blank recording, put it in an announcement, route the DID to the announcement and then to the IVR. I bet that solves the problem.

The strength of the open source community is amazing. This worked like a champ! Thanks SkyKingOH!