IVR With Multiple Languages

Hi folks,
I’m new to FreePBX and this is my first post in here.

I’m trying to setup IVR’s for multiple languages.
What i did was a main IVR like “2 for english, 3 for spanish…” and each option will send the user to anohter IVR recorded on the selected language.

Sound’s pretty easy and works well, the problem is when the person try an ivalid extension the message (“invalid option”) is always in english, no matter which IVR he is on.

Here is what i tried with no sucess:

First of all, I installed all audio files for each language as explained on this article:

And then, i applied this patch (ivr-ml.rev3849±v2.patch) :

After apply the patch, i went to the IVR option on FreePBX and the Language option was there but, after change the language and clicked on the Save button i got this error:

UPDATE ivr SET displayname=‘Main Menu Buss Hours’, enable_directory=’’, enable_directdial=‘CHECKED’, timeout=‘1’, announcement=‘custom/MenuPrincipal’, dircontext=‘default’, language=’’ WHERE ivr_id=‘5’ [nativecode=1054 ** Unknown column ‘language’ in ‘field list’]

After that, i restarted the server, tried again and this time, it saved the information.
The problem is, i can put any language there i have installed (pt_BR, en, fr) it won’t make a difference, the messages always come in english.

Hope somebody can help me with that.

Thanks in advance.

Of course, i have all audio files for each language on their

I haven’t looked at the patch to see if it is doing things properly as that is not the way we are going to go for language (there is going to be a language module). However … if it is being set right, did you check to see if you actually have the given language file that is being played installed. For example, if you are getting language files from Digium, I noticed when looking the other day at the French offerings that they only had the core sound files, they did not have the ‘extra’ sound files of which FreePBX makes extensive use.

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx

Hi Philippe,

Thanks for responding.
Well, the files are there because if i go to the Trunk option and on PEER details i add “language=pt_BR”, i get this trunk working with Brazilian portuguese, the problem here is, if the user is an english speaker, he won’t understand a thing.

New Jersey / USA