IVR with Enable Direct Dial slow response

Hi, with “Enable Direct Dial” enabled on my IVR, incoming calls can be slow to pick up, sometimes taking up to 10-15 seconds as opposed to a consistent 4-5 with it disabled.

Any tweaks for this? If not, can I have a prompt like “press 2 to dial an extension”?

I went ahead and created another IVR with direct dial enabled which can be called from the main IVR by pressing 1. No latency doing it that way,