IVR Question

I am trying to get my IVR to work so that when you choose options from the menu, it rings the extension and then goes to voicemail. The core option seems to do one, or the other. I created a custom-app to take care of this, but am wondering why it isn’t a normal feature?

After having that work, someone testing the IVR chose to directly enter an extension instead of choosing a menu option.

The extension rang, but again, no voicemail. Just endless ringing.

Is this correct, or did I set something up wrong elsewhere?

Calling an extension from another extension, or transfer a call, goes to voicemail on no answer correctly.


I still can not find any good info on this anywhere.


I ended up adding options to the IVR for every extension someone could punch the 4 digit code for, and having that call my custom-app.

Terrible hack.


The voicemail is set on the exten not the IVR

If I call the other extensions from my physical phone on the PBX, and there is no answer, it goes to voicemail.

It is only through the IVR that I have issues with the extension ringing and then going to voicemail.

When I look at the code, the IVR uses ext-local to call

extensions_additional.conf:exten => 5,1,Goto(ext-local,7873,1)

That is the code when I choose Core: and the extension number for option 5 in the IVR.

And if I choose voicemail for the extension on core I get

exten => 5,1,Goto(ext-local,${VM_PREFIX}7873,1)

Which both make sense. But is there something in ext-local that is keeping the voicemail from answering when the first option is in effect.

exten => 5,1,Goto(ext-local,7873,1)

If I create a custom like this

exten => _787N,1,playback(pls-wait-connect-call)
exten => _787N,2,Dial(SIP/${EXTEN},20,r)
exten => _787N,3,Macro(vm,${EXTEN})
exten => _787N,4,Hangup

and then choose custom app instead of core and send it: custom-ah,7873,1

The extension rings, and on no answer after 20 seconds, goes to voicemail.

Looking at the code for the directly entering an extension from the IVR, all I can tell is it must be calling something in ext-local also, which makes sense since it does the same thing, rings the phone forever and never goes to voicemail.


There is no need to set the IVR options to access voicemails from outside. Simply enter “201" (i.e. prefixed with * for extension 201), you go directly to voicemail of 201. Enter "” again to read the voicemails.


Thanks for the suggestion.

Maybe I am not being clear enough with what I am trying to do.

I want someone to choose extension 1 from the IVR.

I want the IVR to ring the physical phone a few times, and if there is no answer, go to voicemail.

The default options for Core in IVR sends to either the phone, or voicemail. Not both. Choosing the extension sends it to the physical phone, but it will ring endlessly without ever going to voicemail. If I set it to voicemail, it bypasses the phone.

I am not trying to check voicemail from outside, I am trying to have an outside customer call the IVR, ring an extension, and if no answer go to voicemail.

I must be missing something simple here (since this seems to be the way my old toshiba and other PBXs worked).

And then again, when someone direct dials an extension from the IVR, like 7888, instead of choosing 1,2,3,&c. I have the same problem. Endless ringing of the physical phone, but voicemail never picks up.

Since this does not seem to be rational behavior for either situation, and both exhibit the same problem, I have to assume I did something wrong. But I sure can not figure it out.

Thank you,