IVR problem.. Cannot uncheck Return on... boxes

The last update that turned on the feature Return on timeout and Return on Invalid keep return checked after submit.

Is that something linked to this article: issues.freepbx.org/browse/FREEPBX-8265

Please help! My system is down…

1 Like

Fount it… It’S realated to the new feature…
Those lines in the ivr.js file are useless…

		$(this).attr('checked', 'checked').val('uncheked')
		$(this).attr('checked', 'checked').val('uncheked')

Why? In the function.inc.php, at the line 521 and 522

$vars['timeout_ivr_ret'] = empty($vars['timeout_ivr_ret']) ? '0' : '1';
$vars['invalid_ivr_ret'] = empty($vars['invalid_ivr_ret']) ? '0' : '1';

Hope the dev will do more tests before publish something… This have screwed up my phone system for hours… (40 users)

There’s only so many tests we can do against user submitted code (this was a third party submission) in the limited time we have. Thanks for your input however.

Of note if you were using FreePBX 12 you could have rolled back to a previous release.

Fixed in ivr v2.11.0.8

I am still seeing the same issue with I’ve upgraded the system as well as the module. I still cannot uncheck the Return on Timeout, or return on timeout.

Seems like your javascript is caching. I assure you. It’s fixed as I removed the offending javascript that was pointed to.

my appoligies, shift-reload seems to have worked. sorry, I normally try everything before posting… I didn’t even think about a cached javascript.


1 Like

Thank you and sorry for this part f the post… I was a little upset…

To avoid this kind of problem, you can add to your list of tests that you can enable and disable any added feature.

Thank you again for the update. This is a great system. :smile: