IVR options gone after Restore from Backup


(Chow) #1

Hi Team

After some help please!
Using FreePBX 15.0.16.44 with Asterisk 16.6.2.

When I run a Backup and Restore onto a new server, the IVR’s don’t seem to copy correctly.
All the IVR options get deleted except for one.

fwconsole ma list | grep ivr
| ivr | 15.0.25 | Enabled | GPLv3+ |

Any help appreciated thanks!
-chow


#2

I had the same experience yesterday. I’m trying again and will file a bug report if I can repeat it.

The other thing that didn’t restore is the names of the extensions that were allowed to login dynamically to queues.

Again, I was going to test again and then file a bug report so they can look at it. But, I wanted to make sure I wasn’t doing something wrong first.


(Chow) #3

Thank you, someone else with the same issue! Thought I had botched something up somewhere. Let me know how you get on?


#4

The IVR option information does appear to be in the backup file. I see all the selection fields in the Ivr.json file. Not sure if that is the only place they should appear.

From a quick glance, I don’t see the dynamic members in the Queues.json. But only a quick look.

I’m spinning up another server to see if they restore and then try to make a small test case.

Honestly - I’ve been super impressed with the new backup/restore! Night and day over years past.


(Chow) #5

I know right, a lot more seamless. Just a few oddities like IVR options and whatever you got going on and we’re in business…


(Kapil Gupta) #6

We have recently found FREEPBX-21258 and fixed the same as well. If your issue is related to this then please upgrade FreePBX-15 backup module to latest edge and give try.
Or else please file bug report and provide your backup file (if not confidential to share on public issue tracking system) for us to reproduce issue locally.

thanks
Kapil


(Chow) #7

Thanks! Will upgrade and test.


(Chow) #8

This didnt seem to make a difference for IVR options. This was after upgrading to edge IVR module. What next?


(Kapil Gupta) #9

please upgrade backup to edge. thanks.


(Chow) #10

Apologies, I meant the backup module, which is currently sitting at 15.0.8.93


(Chow) #11

Here is primary machine with IVR config.

Here is secondary machine with imported IVR config after restore from backup.

This is after updating all modules to latest edge release.


(Kapil Gupta) #12

Are you doing warmspare ?

We have https://issues.freepbx.org/browse/FREEPBX-21325 already open with similar kind of issue so probably you would like to add your comment as well.

If your issue is different, then please raise new issue and provide your information.

thanks.


(Chow) #13

Yes, but I also tried backing up to SSH filestorage as tar file and then restoring from that file on secondary machine with same result.