IVR not working from Alliance Call

I have 3 SIP suppliers. 2Talk in New Zealand works fine. VoIP.ms in USA works fine. Alliance Call. The dtmf tones are not recognised by the IVR. Looking at the logs it appears that the keys are creating double digits. IE I depress 6 and the log show 66.

Can any one make a suggestion on how to over come this problem while not upsetting the other 2 SIP suppliers.

I’m currently using Alliance Call for tollfree numbers in UK and AU. They are rerouteing the calls in my case to SIP accounts. Alliance Call initially helped get their calls to work but that caused the VoIP.ms calls to fail.

One obvious option is to drop Alliance call, but I’d prefer not to unless there is no other alternative.

There’s a DTMF issue somewhere. What were the changes they suggested to make it work?

Cop of email from Alliance Call

Here are some things to try…

In the config file sip_general_custom.conf, enter the following command:


If the above command does not work, replace above command with:


In the config file extensions_override_freepbx.conf, enter the following

exten => _.,1,NoOp(Received incoming SIP connection from unknown peer to
exten => _.,n,Set(DID=${IF($["${EXTEN:1:2}"=""]?s:${EXTEN})})
exten => _.,n,GotoIf($[ “${CHANNEL:0:17}” = “SIP/”
exten => _.,n,Goto(s,1)
exten => s,1,GotoIf($["${ALLOW_SIP_ANON}"=“yes”]?checklang:noanonymous)
exten =>
exten => s,n(setlanguage),Set(CHANNEL(language)=${SIPLANG})
exten => s,n,Goto(from-trunk,${DID},1)
exten => s,n(noanonymous),Set(TIMEOUT(absolute)=15)
exten => s,n,Answer
exten => s,n,Wait(2)
exten => s,n,Playback(ss-noservice)
exten => s,n,Playtones(congestion)
exten => s,n,Congestion(5)
exten => h,1,Hangup
exten => i,1,Hangup
exten => t,1,Hangup

Please let us know if this solves your PBX DTMF issues.

International Communications


That doesn’t need to be put into the general, that can be set on a per-trunk basis. And that’s what it SHOULD be.

allowguest shouldn’t be enabled, as that’s got the potential for hackers to try to send calls out through your machine.

There is literally no configuration where a box exposed to the Internet should have allowguest=yes.

This is a sure way to end up with thousands of dollars worth of calls through your PBX.

There are three dtmf modes. By far, the most common is rfc2833. I’m guessing that you are already using that one.

If you change this, make sure you test your other connections. Changing the DTMF mode can break the working configurations.

The changes recommended in

doesn’t seem to answer the actual question you asked. Your original problem was that you were getting double DTMF, not that you weren’t getting connected. Looking through what that context does is interesting (they seem to allow anonymous connections from their IP address) which doesn’t fill me with hope. Connections from them are succeeding, the problem seems to be more that the IVR isn’t working.

If you can set the DTMFMode in your trunk definition (I haven’t looked in a long time), you might want to limit your DTMFMode changes to the one trunk you are having problems with.

The problem with the per trunk approach is because of the way they redirect the calls to SIP the trunk settings is redundant and any changes I made to the trunk entries had no effect. Consequently I have deleted the trunk entries.