IVR not reacting to external dial tones

After having fixed the connection issue, I thought I give the digital receptionist (IVR) a quick try. I followed some manuals to set it up and assign it to a misc. application for testing (code 9999), and made it the destination of the inbound route.

If I dial 9999 or the external number from a softphone on one of my PCs, everything is fine. The IVR reacts as I had programmed it.

When I try to call the number from a different phone (I have tried 3, 2 landlines and a cell phone), it is as if the IVR does not recognize the dial tones. It plays the initial announcement 3 times, then hangs up.

Any ideas what that could be?

You likely have the dtmf settings wrong on your incoming route.

DTMF mode is set in the peer not in the route.

Pleas see my response to your other post with regard to the proper terminology of dial tone.


I have tried

dtmfmode=inband, rfc2833, info and Auto. In addition I have tried rfc2833compensate=yes and relaxdmtf=no. No changes.

Of course I tried to talk to the Broadvoice guys, but they tell me that they can’t help me, that the dmtf from their side comes as rfc2833 or inband, but I have tried that and Asterisk does not seem to recognize them.

You can debug rtp and see the rfc2833 messages arriving from Broadsoft.

Place a call, turn on rtp debug and hit a few keys, you will see a message that looks like this.

[Sep  8 01:30:14] Sent RTP DTMF packet to xx.xx.60.164:9780 (type 101, seq 008267, ts 221648, len 000004)

You will see the “Got” side also

Thanks for your help.

Forgive me asking, but how do I turn on rtp debug? In CLI? a terminal? Do I have to download an application? Also, Where do I find the log files for Asterisk and freePBX?

It’s an Asterisk CLI command.

rtp debug on and rtp debug off

If you don’t know the syntax of a command you can use the tab key to complete a keyword and a ? to display the acceptable arguments to the command.

Hmm, when I type ‘rtp debug on’ at a CLI prompt, I get “No such command”. Do I have to istall that in Asterisk first? I am using the AsteriskNOW distribution (1.7.1)

Nope from the asterisk CLI:

vg2*CLI> rtp ?
debug  no     rtcp
vg2*CLI> rtp debug
ip   off
vg2*CLI> rtp debug ?

See how you can pot a ? and find out the syntax.

It’s a bit strange on my machine. When I hit the “?” button, it seems to paste an older command in there. But anyway, I got the rtp debug running, but all I get is line after line of the following text:

Got RTP packet from (type 00, seq 029735, ts 3555014099, len 000160)

The seq and ts numbers are changing rapidly. Do I need to change verbosity somehow or filter the output?

No, those are the audio packets.

If you don’t see the DTMF your carrier is not sending it via RFC2833, it must be inband or SIP info method.

I think you are right. I did try setting the dtmfmode=inband, but that didn’t work either. But for now I have again a bigger problem. I am not connecting to Broadvoice (again). This whole experience is turning into an absolute nightmare…

Yeah bad terminology on my part.