IVR not accepting # for input (was: Directory default announcement not working)

asterisk
freepbx
Tags: #<Tag:0x00007fafd3266170> #<Tag:0x00007fafd3265fe0>

(Howard) #1

OK, I am thinking something got busted along the way, but just got asked why when you enter the company directory, it no longer gives you the default prompts on how to use it.

Sure enough, I called in and when you enter the directory from an IVR, it just sits there in silence, even though it is very much set to the default announcement. So then I went and tried it on my personal system as well, and sure enough it’s broken there as well. I tried rolling directory back a verson or two, but still no go.

I am running the current PBXact 12.7.6-1910-1.sng7 under Asterisk 13.27.1 as I made sure I was on the current release.

On the funny side, I tried to make a system recording and just put my own voice in as the prompt, but still I just get silence, so for some reason the directory module is not playing the initial announcement.

Any ideas or help would be great…


(Psdk ) #2

It would be good to check Asterisk console logs and see what’s going on when you enter to directory.


(Howard) #3

This has gotten more interesting as I dig into it more. It’s not the directory, that seems to be fine, it’s the reading of touch tones. I have always had directory so if you hit # it entered the directory. It seems that for somereason it’s getting the # but not acting on it, if I change that to some digit, say a 6 or a 9 (which I tried) then it enters the directory. If I leave it at # it pauses for a min when hit like it was thinking about doing something, then says no valid response.

I tried this on an older FPBX and it worked fine, but on my current PBXact systems the # option seems broken…


(Dave Burgess) #4

There were some changes to the IVR module recently that broke some stuff. Hash/Pound Key Not recognized in IVR anymore for example.


(Shri) #5

We rolled back to 14.0.3 from 14.0.9.4 and everything is working as it should be again.


(Howard) #6

Does anyone know if Sangoma has a bug report open on this item? If not I am guessing one should be filed…


(Jared Busch) #7

Directory or IVR? If IVR, is your IVR set to No - Legacy?


(Howard) #8

IVR Legacy mode? Huh??

I even went back and looked, I see no such options in my menu, and my IVR is version 14.0.9.4 currently in my PBXact. I even looked in advanced settings and see nothing about Legacy, but know that up till a short while ago, my IVR worked fine and accepted # as an option…


(Jared Busch) #9

Roll back your IVR module then until they push the rest of the updates to PBXact.


(Howard) #10

Exactly what I did, I found when I rolled back to 14.0.5 it all started working, but with 14.0.6 it was broken. I will make sure it’s reported…


(Howard) #11

Issues Ticket opened: https://issues.freepbx.org/browse/FREEPBX-20778