IVR Menu Doesn't Recognize Extension Selection


(R3d10) #21

Thanks. What would you suggest as a first step in debugging DAHDI?


#22

Either by R’ingTFM’s or posting your current configs ( all of them)


(R3d10) #23

Thanks. I put these config files in Pastebin. Let me know if this isn’t the best way to share my config. (I am learning as I’m going, and I appreciate all the help so far!)

asterisk.conf
https://pastebin.freepbx.org/view/769a62cc

chan_dahdi.conf
https://pastebin.freepbx.org/view/7d699d7d

dahdi-channels.conf
https://pastebin.freepbx.org/view/009b03a8


#24

And all the #included files are otherwise non-existant or empty?

How was DAHDI originally configured?


(R3d10) #25

Here’s the config files referenced in the files previously posted:

chan_dahdi_general.conf
https://pastebin.freepbx.org/view/3d0d6152

chan_dahdi_general_custom.conf
File exists, but completely blank.

chan_dahdi_channels_custom.conf
File exists, but completely blank.

chan_dahdi_groups.conf
https://pastebin.freepbx.org/view/d3d2b1ae

chan_dahdi_additional.conf
https://pastebin.freepbx.org/view/d0e149ba

There is also this dahdi conf file:

chan_dahdi.conf.old
https://pastebin.freepbx.org/view/60fdda2c

The phone server was set up before my time, so I’m not sure how it was originally configured.

There are many, many other .conf files under Admin > Config, but these are the dahdi files I see.


#26

Apart from

  1. busydetect=yes
  2. busycount=10

probably not needed for a PRI (plus a lot of other parameters), then perhaps add

dtmfmode=rfc2833

(R3d10) #27

So I should remove busydetect=yes and busycount=10 and add dtmfmode=rfc2833 to chan_dahdi.conf?


#28

If you want to :wink: although I would have thought rfc2833 would be intrinsic to a PRI though.


(R3d10) #29

@dicko, I tried this and it only made the phones stop working. Can’t call in or out, just get an ‘all circuits are busy.’

The thing is I switched it all back, restarted Asterisk and DAHDi, and it still won’t work. Even after rebooting the server. Any ideas on what could have happened?


(R3d10) #30

Here is what happens when I try to call out:

https://pastebin.freepbx.org/view/d69434a9


#31

I would start over from scratch perhaps referencing :-

https://support.digium.com/s/article/How-to-configure-a-Digium-T1-PRI-card

I would not rely on the GUI dahdi ‘Helper’


(R3d10) #32

Ok, seems like starting from scratch on configuring might be a good idea. In the meantime, any idea on what might be causing the busy signal on inbound/outbound calls? It’s weird that it still isn’t working even though I changed the settings back.


(R3d10) #33

I’m hoping to get the phones to work again making inbound/outbound calls. Should I start a new thread on the new issue I’m having, or continue on this one?


#34

There are a number of ‘helper tools’ that come with dahdi

http://docs.tzafrir.org.il/dahdi-tools/

dahdi-monitor show channels going up and down the other ones more for setting up.

You could also enable PRI debugging and see if the calls are even getting to the DAHDI driver.

Be aware that the PRI logs are not initially easy to understand.


(R3d10) #35

Thanks. I ran ‘dahdi show channels’ and Chan Extension is ‘pseudo.’ I think this might be the issue, is there a quick way to resolve it?

I definitely want to solve my original issue, but I’m feeling pressed to just get the phones working again asap. Any help with getting these phones up would be greatly appreciated!


(R3d10) #36

Update: I got the phones back up. Made a change to Group Settings under DAHDi Configuration.

Now I will try to get back to work on the original problem!