IVR Invalid and Timeout routing issues

Hello all:

Using FreePBX Distro 2.10.

There might be a bug in the IVR module with the invalid and/or timeout option settings. Either that or I just don’t get something, which is ENTIRELY possible.

I’m not a noob though I’m not exactly an expert either. Most times, I don’t have too much trouble getting the PBXs setup. Anyway, on to the issue…

The IVR ‘invalid option’ announcement plays then just sits there…and invokes the ‘timeout’ announcement and options instead. Eventually the call disconnects as that’s what I’ve specified. What gives? An invalid options usually means the caller didn’t hear all of the options correctly and wants the IVR menu to repeat. But I can’t make this happen. If I set the IVR announcement as the ‘invalid’ retry message, it plays but doesn’t responds to keypresses - so obviously no longer in the IVR. I’d enabled the ‘return to IVR’ setting in the ‘invalid’ announcement but that wasn’t working.

Another things is that the timeout message plays a few times then terminates the call (chosen setting). This too does not replay the IVR menu announcement. So, how is the caller supposed to hear the menu again in case they missed something.

What is wrong and/or what am I missing. Maybe, what’s wrong is that I’m missing something.

I think I liked the good old ‘i’ and ‘t’ destinations better.

Thanks in advance

The ‘t’ is also gone, I think, though I haven’t tried it explicitly - I got stuck on the ‘invalid’ option config. There are two types of ‘i’ recordings and I don’t know why. I’ll play with it a bit more in the off-hours but if anyone has experienced this please join in.


You need to specify your “i and t” destinations. Roll over the blue circle on the web page for tool tips on how to configure.

Also our documentation link has extensive instructions on using the IVR.

Honestly I am having a hard time figuring out what you are doing wrong wrong.

I forgot in 2.10 the I is done away with and the invalid destination is set in a drop box. The invalid retry recording simply allows you to play a recording before moving on to the invalid destination.

Thanks for the response SkykingOH.

I tried specifying ‘i’ and ‘t’ destinations in the IVR Entries section but it doesn’t seem that they do anything.

Above that, in the ‘IVR Options (DTMF)’ section, it looks like if the Invalid Retry Recording and the Invalid Recording have the same announcement specified, a Timeout condition seems to be activated, the IVR Announcement never repeats and the call finally terminates.

What is the purpose of having settings for both an Invalid Retry Recording and Invalid Recording? And why would a ‘0’ count as a potential ‘invalid’ option? I’ve been using FreePBX since 2006, I think, and this section seems a bit complicated or not well laid out.

But, like I said before, maybe I’m just missing something…