IVR hangup when wrong extension is dialed

Hello Everybody,

I have a strange Problem with our IVR Module.
Our IVR is perfectly working, meaning when I dial 1 or 2 to get to the setup IVR destination it is working well.
When I dial a IVR Destination which is not setup, I get “we have not received a valid response” which is supposed to be like this. Also when I dial an extension, its getting routed to the extension.
But, when i dial a wrong Number which is longer the 2 digit, the System hangs up, unless I dial this Number and get put a # behind, then I get the write announcement “we have not received a valid response” again.
The Error I get, when I dial a longer Number then 2 digit in the IVR is:

[2016-06-19 19:03:34] WARNING[27115][C-000000d6]: pbx.c:6763 __ast_pbx_run: Channel ‘SIP/CN-TCom-0000011c’ sent to invalid extension but no invalid handler: context,exten,priority=from-did-direct,875,1

It was working well in the past and I just came by chance across this Problem when I added new Music to the System and started some Test’s …

Anybody experienced something similar or has any idea where I could look …

thanks for your help,
Cheers, NUB

Configure the invalid option in your ivr. If you are using the default one you should add an option with letter i as the ivr option.


& thanks for your advice, I actually did configure the invalid option in my ivr.

  • invalid Retries = 3
  • invalid Retry Recording = default
  • Append Announcement to Invalid = Yes
  • Return on Invalid = No
  • Invalid Recording = default
  • Invalid Destination = Extension / 800 (our reception)
    Its working for 1 and 2 digit invalid inputs but not 3 or more.
    Meaning input 5 would give the right invalid response, input 55 also, but 555 not, here the System hangs up, same as for 5555 or more …
    But 555# or 5555# would work again …
    I tried to debug, but the only thing I got is what I was already describing …

This looks like a bug, file a report at http://issues.freepbx.org

Try to add an option with the letter i and send it also to extension 800. Try again and if it doesn’t work you can add in your extensions_custom file the ivr-custom context and fix the issue from there. As @Igaetz suggest might also file it as a bug.

Hi astbox,

I don’t really get it, where should I add ad option with the letter i ?
I tried in IVR Entries, where I also define for example 0 for Reception or 1 for … etc., but I cant have a letter here, only digits ?
Or I maybe fully misunderstand,

sorry & thanks

Yes, instead of a digit try to fill the letter i, if freepbx doesn’t allow it then the only alternative is to add it through the custom context of your ivr. Couple of versions back you could add a letter as an ivr option but I haven’t tested it in the latest freepbx version.

Hi & thanks a lot for your help, unfortunately FreePBX 13 does not support an Character, only Digits.
I maybe really report this as a Bug, as lgaetz suggested.
I will keep you posted here, for the response I get.
thanks NUB

Dear NUB,
I have same issue on my FreePBX 13. Have you got any response from bug-tracker?

Hi Davyd,
yes, actually it looks like the Ticket is now in the Status “On Deck” in their Agile Board, which, as I understand means it is in pipeline to be solved.
You and me are not the only one with that Problem, so maybe we will get an Result pretty soon.
I will keep keep everybody, who follows here posted and also, of course post, the Solution, once it got solved.

i have the same issue.Have u got any response ?

Any updates?

Experiencing the same issue here. Using an IVR to allow people to dial by extension. When an invalid extension is dialed, for example 6000 and all the extensions are 3xxx, the system just hangs up the call.

Invalid destination is set - to no effect
Append Announcement to Invalid - no effect
Invalid Announcement - no effect

Invalid (features) only seem to work for single or double digits, anything else other than a valid extension just hangs up the call.

Found bug looks identical to the original post here: xx:// /issues.freepbx.org/browse/FREEPBX-12577

It seems a bit more serious as its not just related to extensions. Dial any 3 or 4 digit number in any IVR (that isn’t matched) and the call is disconnected.