IVR/dtmf stops working once Local Networks field is not blank

Greetings,

I have a noodle-scratcher for anyone who’s up for the challenge, I believe the majority of information you’ll require I’ve compiled here:

http://pastebin.com/wyyPi5sk

The IVR breaks when “Local Networks” is entered in NAT settings (FreePBX web interface > Settings > Asterisk SIP Settings), but when it’s blank it works. I will get you anything else you request and answer all your questions. I can’t seem to find anyone else experiencing a similar issue and I’ve been looking for weeks before asking for help, I would be grateful for any assistance you could provide and would appreciate being pointed in the right direction.

Thank you!

You neglect to say what your local network/netmask actually is, from bash:-

ip -f inet addr show

My apologies,

[[email protected] ~]# ip -f inet addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    inet 127.0.0.1/8 scope host lo
2: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    inet 10.10.7.106/24 brd 10.10.7.255 scope global eth1

https://doc.pfsense.org/index.php/Asterisk_VoIP

Thanks dicko! I have tried that earlier in the week and after following those steps, I was no longer able to make or receive any calls, but I will give it another try and maybe I’ll see something I missed the first time.

I’ve been starting to feel like pfsense is the potential culprit… thanks for the reassurance.
Here are a couple other links I’m studying that are supporting that theory:
https://doc.pfsense.org/index.php/VoIP_Configuration

Well either siproxd or better yet 1:1 pass through if you have a network larger than /32 should work

(an EXTERNAL network larger than /32)

I solved my issue!!!

https://doc.pfsense.org/index.php/Static_Port