IVR Direct Dial dont work

FreePBX 10.13.66-20
FreePBX 13.0.192.8
Current Asterisk Version: 13.15.0

I set simply IVR:
Announcement = Ann1_g722
Enable Direct Dial = Enabled

but when i test it, and try enter number XXXX, i get a message that says we have not received a valid response.

After some investigations i found that Direct Dial work ONLY with local extensions!
Its don’t work with “Misc Applications” numbers, don’t work with Queues numbers, and don’t work with numbers on other PBX!

But we need Direct Dial to ALL numbers!

How to do it?

Up !!

Those you add under IVR entries:

I need dial numbers on other PBX.
I do not use ivr entries.

I e.g. have a range of numbers on another PBX and I make those dialable from my IVR through some custom dial plan in extensions_custom.conf

In below example 4 digit numbers in the 1000-3000 range are dialable from my IVR and sent out the trunk to another PBX.
FreePBX starts numbering the IVRs that you create from the GUI with ivr-2 being the first, ivr-3 the second and so one.
Below dial plan adds to the one generated by FreePBX.

[ivr-2](+)
exten => _[1-3]XXX,1,goto(outbound-allroutes,${EXTEN},1)
exten => _[1-3]XXX#,1,goto(outbound-allroutes,${EXTEN:0:4},1)

If you don’t have numbers in a specific range on the other PBX and you have just a few, you can also create a custom extension on your local PBX for every one you have on the other PBX and use local/[email protected] in the dial field under the advanced tab of the extension and add it as an IVR entry.

You can create a Directory with all of the numbers IVR callers are allowed to input and then change the “Enable Direct Dial” to the name of the directory:

avayax
where (and what) in the web-interface I have to add in order to be able to type XXXX numbers?

lgaetz
totally unacceptable

You can put this in extensions_custom.conf from the GUI using config editor under admin. (Of course change [1-3]XXX in the example to your numbering scheme).

[ivr-2](+)
exten => _[1-3]XXX,1,goto(outbound-allroutes,${EXTEN},1) 
exten => _[1-3]XXX#,1,goto(outbound-allroutes,${EXTEN:0:4},1)

Just make sure the ivr numbering is correct. So ivr-2 would be the first IVR that you have created from the GUI, ivr-3 the second etc. (You might have to verify that and debug the dial plan)

I tried

[ivr-3](+)
exten =>; _XXXX,1,goto(outbound-allroutes,${EXTEN},1) 
exten =>; _XXXX#,1,goto(outbound-allroutes,${EXTEN:0:4},1)

(also tried [ivr-2])

but direct dial still not working

Sorry, I had a typo in my dial plan.
Delete the “;” after the exten =>

I corrected it above.
If it doesn’t work provide dial plan debug.

You can put dial patterns (with leading underscore) in a Directory, or you could the last time I tested.

Then use Igaetz solution, which doesn’t require you to add custom dial plan.

avayax

thanks, now it works!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.