IVR Audio

Hi there everyone.
I’ve been using FreePBX for some time now and I’ve always sorted the problem out by searching the next but this one is not having any of it.

I did a fresh install of FreePBX on a new server and setup as normal.
The problem I’m having is that when I call in I do not hear the IVR announcement, but if I press a button it places me on hold and plays the OHM and directs me to the correct queue.

I’ve tried recreating my wav and encoding them using sox, I’ve copied my old recordings across to try them, I’ve even tried setting the announcement as one of the OHM files to see if that works but it doesn’t.

I get perfect sound otherwise both ways.

Any help or direction would be appreciated :slight_smile:


Did you record the IVR recordings on the new machine, or copy the recordings over? If the latter, you might have a file permissions problem.

chown asterisk filename

should solve the problem. If not, then try

chmod 644 filename

I’ve fixed the problem, changed to verbose and watched the call come in.

I missed this line about 10 times; 'audio is not mono 2’
So went into Audacity changed it from Stereo to Mono which it should have been anyway, set the compression to 8kHz uploaded changed permission to asterisk worked perfectly.

I couldn’t believe I’d missed it.