It changed overnight: all calls to two different FreePBX servers are silent

Hello there,

I am facing a strange behaviour of my FreePBX servers (both of them!).

We are using SIP clients on smartphones to call.
Overnight, it changed and the servers stopped function normally:
all calls dialled get connected, but only generate silence.

Calls do not drop, and I do not think it is a NAT issue, since I used the same set up for last few months and no changes have been made.

What is interesting, I am still able to get through to the call using Bria Softphone.
However, Zoiper, CSipSimple and everything else only get silence, nothing else.
Both servers got Static IP’s.

This is very strange since no settings have been changed on the servers. Does anybody know where I should look for errors?

Running FreePBX 12.0.37, Asterisk 13, PJSIP extensions.

Is it one-way audio or no audio at all?
chan_sip or pj_sip?

I had a lot of one-way audio issues which pointed to NAT issues, but we have no NAT involved in our setup. However, we have VPN connections across multiple subnets. At one point, audio stopped working from specific subnets.

Double check:
-Settings > Asterisk SIP Settings > NAT settings (Make sure local networks and external address are correctly set, and make sure netmask is entered using non-decimal form, i.e.

-Settings > Asterisk SIP Settings > Chan PJSIP (Make sure local network and external IP address are properly set. Make sure local network is set like :

This solved all the issues I had with lost audio in some calls. And, like you, they suddenly started happening for no reason.

could be firewall also. I had this happen and then I just reset my firewall and it worked. At least for a little while.

Thank you for the advise.
It was no audio at all.
Chan_SIP worked fine (port 5060), just had problems with PJSIP (port 5061)

I have changed ports so that PJSIP runs on 5060 and Chan_SIP on 5061, and PJSIP started to work and Chan_SIP extensions stopped.
Again, with Bria all of them worked for some reason all the time, but with most of other SIP clients all calls on port 5061 would go silent.

Now, after a couple of days, both SIP on 5061 and PJSIP on 5060 are working fine again, no problems at all.

Still do not know what have hit me, I run latest FreePBX Distro, could it be Fail2Ban?